See Rooting new hardware FIRST if you have a nook original with a 1003* serial# or above.
Belated congratulations to [mbm] and pokey9000 for rooting the Nook Color. Check out our Nook Color portal also.
User:TimRiker has been re-despamming. New user registration disabled for a while. Need wiki help? Contact an Administrator.

Talk:Rooting New Hardware

From nookDevs

Jump to: navigation, search

I read through the directions and I think that I understand. I just wanted to clear something up. Is it not yet possible to downgrade a nook that has firmware 1.5.0 preloaded? Thanks!


Very nice cdump! And easy to fix by next b&n firmware update :) --Spec 07:56, 15 October 2010 (PDT)

Yes, easy to fix. So, disable auto-update (FAQ#How_do_I_disable_B.26N_updates) after root first. --Cdump 08:14, 15 October 2010 (PDT)


I would think that once softrooted, the adb can be used to install the "dd" binary and be run to get a dump of the System SDCard ... ??? that new firmware could then be used to create a new "softroot" for use the same way as the old one, even if they fix the hole you found...--Shadow007 08:35, 15 October 2010 (PDT)


I don't know if this space is for this, but thank you, with Dark Alex you are my hero. Because I'm in Brazil, I can't buy another nook easily, I will wait for new softroot or more guaranteed method. And as I am developer, start to create new apps. Thanks again!!!! Please softroot developers, can you do this? Maybe just a better tutorial explaining all steps to minimize chances of brick. --Dark Steybow

Thank you, I rooted my 10031 / 1.4.1 nook with this, since I use apache and perl was not working for me, I used different files http://pastie.org/1226757 Andphe

Actually, there is no need to re-send request to B&N server as you and cdump did in your scripts. I'm using plain XML file wrapped to .php script for this: http://217.20.163.111/sync/001/Default.aspx. Scripts are up and running on my site you can just adjust your DNS server to point to 217.20.163.111 instead of *.barnesandnoble.com. There is also an article how to install firmware from Mynook.ru with this hack: http://blog.runserver.net/2010/10/nook_16.html (sorry, russian only). Nomad 06:16, 18 October 2010 (PDT)

Excellent. Any up for translating this document (above link) to english? I am looking forward to rooting my nook.

I find it's pretty understandable using Google Chrome to translate it. Dr. Skullthumper 14:12, 18 October 2010 (PDT)
I want to root my nook too, but my little knowledge how to configure don't help me to make it work. Following the Nomad link, don't work for me, certainly wrong step. Just some informations how to configure my d-link wireless router with the basic and working, I will post here more detailed how to with pictures.--Dark steybow 21:15, 18 October 2010 (PDT)

Contents

Next steps

I followed the instructions and can now adb connect to my nook, but I have some questions:

  1. In step 6, "Modify /init.rc to enable adb", do I just add /sbin/adbd & to the end of /init.rc? Is the & necessary? I could try both ways but I don't want to accidentally brick my nook.
  2. How do I continue from there to launch .apk applications installed with adb install *.apk? I don't want to replace the original nook home menu, but I read in this page that it's possible to make the chess icon launch Nook Application Manager. The page doesn't have any instructions on how to do it (either that, or Chrome's auto translation is mis-translating something), and the page for Nook Application Manager doesn't have a download link or instructions. Any ideas?

Thanks. Imgx64 01:51, 20 October 2010 (PDT)

1. You need to find line "service adbd /sbin/adbd" in init.rc and change "disabled" to "enabled" on the next line.
2. You've to push modified Home.apk to /system/app. It is available here: http://runserver.net/nook/Home.apk .You could just write it to device with "adb push Home.apk /system/app/". I'll try to make a new version recently with additional buttons added instead of replacing the chess. --Nomad 02:32, 20 October 2010 (PDT)
Thanks, it works greatly now. Imgx64 07:53, 20 October 2010 (PDT)
There is new version of modified Home.apk available - instead of replacing 'Chess', I've integrated own app manager. 'Games' folder becomes 'Apps' where you can see all installed custom apps icons. Uninstalling with long click is also here. Grab it at http://runserver.net/nook/Home.apk --Nomad 01:07, 23 October 2010 (PDT)
My advise is that once you have adb enabled just install the original nookLauncher and nookMarket from nookdevs.googlecode.com . You will be able to rearrange icons, create folders and download all the good apps using those 2 pieces software. I wouldn't install any "new versions" of Home.apk as, what mynooklauncher.ru showed, it only creates a big and unnecessary mess on the device. --Spec 07:50, 23 October 2010 (PDT)
One simple picture to show why I think you are wrong: http://img232.imageshack.us/i/apps1.png/. Just the same B&N original launcher with simple and plain list of installed apps. But.. it is for you to decide what to use. :) --Nomad 08:41, 23 October 2010 (PDT)
What am I looking at? Messed up menu? What is on that picture that I can't configure with vanilla nookLauncher? --Spec 10:59, 23 October 2010 (PDT)
Actually, that is 'Games' folder sliding from the right in default B&N launcher. And yes, you are right - there is nothing special that you can't do with nookLauncher/mynookLauncher/command line/whatever. But I'd really prefer apps and interfaces created by skilled B&N designers rather than home-brew stuff. --Nomad 12:05, 23 October 2010 (PDT)
Apps created by b&n are all there untouched in nookLauncher. nookLauncher 0.1.0 (released after the softroot 2.4.1) is identical to home menu in orignal 1.4.0 firmware as far b&n icons - b&n icons were copied 1 to 1 from original b&n menu. if not for configurable menu and homebrew apps you wouldn't be able to tell the difference (maybe only by missing title bar on top of the eink). I also prefer original b&n icons and they are there in nookLauncher 0.1.0. --Spec 20:37, 23 October 2010 (PDT)

TFTp32 Alternative for Mac OS ?

Hi, what programm can i use on an iMac?

Thx

rerouting update using dnsmasq on router with dd-wrt

I have flashed the firmware on my router with the linux-based dd-wrt firmware. I highly recommend it: http://www.dd-wrt.com.

My setup is as follows:

Router Name DD-WRT

Router Model Linksys WRT54G/GL/GS

Firmware Version DD-WRT v23 SP2 (09/15/06) std - build 3932

DD-WRT firmware allows you to run DNSMasq on the router and I believe does so by default.

Taking advantage of this greatly simplified the routing process for me.

First ensure that you have checked the "Use DNSMasq for DNS" option on the main setup page using the dd-wrt web GUI.

Then add these 2 lines to the startup script for the router using the administration/management/commands window on the dd-wrt web configuration interface:

echo '217.20.163.111 sync.barnesandnoble.com edmfiletransfer.barnesandnoble.com' >> /etc/hosts

killall -HUP dnsmasq


Once the router was rebooted, nslookup reports the following:

> sync.barnesandnoble.com Server: 192.168.1.1 Address: 192.168.1.1#53

Name: sync.barnesandnoble.com Address: 217.20.163.111

> edmfiletransfer.barnesandnoble.com Server: 192.168.1.1 Address: 192.168.1.1#53

Name: edmfiletransfer.barnesandnoble.com Address: 217.20.163.111

Success! Thanks all the Nook is good.

--Randomizer 21:42, 24 October 2010 (PDT)

p.s. Make sure you restore your DNS as soon as you are done updating!

Automated Root

I created a version of wifi_stop.sh that you can use that'll automatically modify your init.rc and install busybox.

Actually, scripts on 217.20.163.63 are uploading wifi_stop.sh modified to call /system/media/sdcard/root.sh. That is how packages (mynnook_package.zip and nomad_package.zip) works. --Nomad 07:48, 26 October 2010 (PDT)


How to use:

Download the following files to go on your nooks internal card (the one that says nook):

http://nookdevs.googlecode.com/files/nookLauncher.apk
http://nookdevs.googlecode.com/files/nookMarket.apk
http://benno.id.au/android/busybox

Replace the wifi_stop.sh script inside file.dat with the one from here: http://pastie.org/1247181

Run the following command to clean up wifi_stop.sh: adb shell busybox sed '9,$d' /etc/wifi_stop.sh

Changes:
v1.0: Initial
v1.1: Enables Non Market Apps and installs nookLauncher.apk and nookMarket.apk without user input.


I got 3 questions:
1. I know what busybox is, but I dont know what homebrew software uses or requires it?
2. Since B&N provides busybox source code on their nook/legal page, doesnt it mean it is already installed, you just need to create symlinks for the tools that are compiled into it?
3. Installation of non market apps is discussed in Trook Documentation, but is that required by nookMarket too? If not, then I stand by my previous statement that once adbd is running all you need is nookLauncher and nookMarket - you can install 100% of nook homebrew from there from the touchscreen. I'm not sure if anyone uses Trook to install apps anymore. --Spec 18:49, 24 October 2010 (PDT)


Busybox isn't apart of the nook already, which is why it has to be installed, this script requires busybox so that it can modify init.rc to enable ADB permanently. As for the Installation of non market apps, it's required to install any sort of software without using ADB. I'm currently working on a v2.0 which will modify the database automatically, and once I work it out will install either a modified Home.apk (like the one above) or nookLauncher.apk and also nookmarket.apk and clean up wifi_stop.sh so that users just have to turn off their wifi once and they're good to go. What I'm attempting to do here is make this process of rooting as simple as possible for all users. --GabrialDestruir 04:25, 25 October 2010 (PDT)

The reason I'm curious is that if you look at nook legal page there's nook source code download there. If you open it, it contains 3 tar files one of them is bravo_busybox.tar . So I guess it must be there in vanilla nook somewhere otherwise why would they include it in nook source code. --Spec 07:29, 25 October 2010 (PDT)
Well it does make sense that it'd exist as it's part of the source, but as far as I know, and if someone knows otherwise I'd be glad to hear, there is no busybox within a vanilla nook that's accessible through the shell, which is why it has to be installed. --GabrialDestruir 15:04, 25 October 2010 (PDT)

Hey i Am a bit confused. I should download the 3 files and put them inro my nook-folder, ok. But where can i find the data.dat ?

Do you mean the one cdump posted earlier? If yes do i need the nook.pl file? If so, i dont understand what cdump means with document-root If i will do it your way there is no need for the DHCP/tftp32 stuff or?

Thanks for help

This is a supplement to cdump's work. This is a replacement for the contents of file.dat, which is the file that gets copied on top of wifi_stop.sh, that does some of the post-root work for you.
document-root is the folder that the web server is serving pages from.
You'll still need to do all the DHCP/tftp32 stuff. Izzy84075 08:23, 25 October 2010 (PDT)
It does replace the file.dat so what really needs to happen is this file needs to be hosted by nomad or someone that'll allow users to redirect to it. The newer version does everything but clean up wifi_stop.sh so if the files were hosted and someone made a proper step by step guide the rooting process could be done in just a couple of minutes without risk to 1.4.x users. --GabrialDestruir 15:04, 25 October 2010 (PDT)

Does anybody know if this would work on a Nook with a 10035 serial?

What's the software version? This is known to work on 1.4.1 and 1.4.2, not a particular serial number. --Izzy84075 08:05, 26 October 2010 (PDT)

Battery Drain

I and many other users have noted extreme power drain after rooting. The issue seems to be with some nookdev apps. No-one has properly diagnosed this. Fixes suggested are -- reboot the nook after any wifi activity. Install and use TaskManager to stop tasks not in use.

If you are experiencing this problem, sign your name below. I would like to have a group of people working together to diagnose the problem by differentially disabling apps to see what makes the problem go away. Once a candidate app has been isolated, a collective code audit may allow us to identify whether there is a way to solve this once and for all.

People below are having power drain problems with rooted hardware

--Randomizer 05:24, 29 October 2010 (PDT)
Firmware - 1.4.1
NookDevs apps:
all apps installed by nomad's first script on Tommy's Root Details page
Very first version of my script makes file wifi_stop.sh blank meaning that WiFi would always be on. You need to restore the file manually (just put http://runserver.net/nook/wifi_stop.sh to /etc/ forlder) or install current version that have this problem solved. --Nomad 07:00, 29 October 2010 (PDT)
In my case, at least, I fixed this manually and am still experiencing fast battery drain. More investigation required on my side. If others can add data points, the problem may be more easily tracked down. As they say in the Open Source world -- to many eyes, all bugs are shallow.[1]
--W33ble 12:29, 11 April 2011 (PDT)
Serial: 1005* | Firmware - 1.5.0 rooted from 1.4.3
NookDev Apps: nookMarket, nookLibrary, nookSync, WiFi Locker, Task Manager, busybox
Have adb off by default in init.rc. Originally installed Trook and thought that was the problem, so I re-rooted and kept that off the list; didn't help. Recently modded my /etc/wifi_stop.sh, added the following at the end in hopes to have the problem solved (busybox required) - busybox killall adbd - So, that runs ever time I enable airplane mode. Hoping that with Wifi off and adb killed, I'll be ok. Still on 1.4.3 ATM, planning to upgrade to 1.5.0 if this works. Tired the fix below but it didn't help at all.
4 hours in and I've only lost 7% battery. I suspect that's on par. My battery might be weaker as the unit I bought was refurb, but this is tons better than I was getting before. Initial observations seem to indicate that 1) adb is a significant drain on the battery and that 2) WiFi Locker isn't stopping it properly when it claims to be. Instructions posted here, more news to come...
People below are having power drain problems with un-rooted hardware

Fixed?

I had this problem and I believe I have fixed it. The nook would completely drain overnight if wifi was used the evening before. After a long search I discovered that the wifi_stop.sh script had ownership root:root, whereas wifi_start.sh had ownership 515:516. I believe this may cause the nook not to be able to actually run the wifi_stop.sh. I went through a rather involved procedure to recreate the script with correct ownership (main difficulty was that there is no user 515, nor a group 516). After this, it appears the battery drain issue is gone. If there is interest I can post the procedure. -- Drdude 09:33, 10 November 2010

I'd be very interested in the procedure if you could post it. It does seem to work as root, though, as if I turn off WiFi, it kills pings to the nook immediately. The only app I'm running are the Library and Launcher, and the battery seems to last 24 hours. -- Meathe 07:57, 11 November 2010

OK, here goes: [there used to be an elaborate description here but I replaced it with a better way a buddy of mine found]

  • install busybox if you haven't already (it may or may not have already been installed by the rooting, it is unclear to me)
  • start a shell to the nook on a PC with
adb connect <nook IP address>
adb shell
  • in the shell, do the following:
cd /system/etc
ls -l wi*                            
busybox cp wifi_stop.sh wifi_stop.sh.backup
busybox chown 515.516 wifi_stop.sh
ls -l wi*

some notes:

  • this replaces a very awkward earlier procedure
  • kudos to Wouter for telling me that busybox's chown works here
  • standard disclaimers apply, if this bricks your nook it is your problem, not mine (sorry). That said, with the backup made in the third line and all of the unbricking techniques around I would say the risk is minor.
  • the first
    ls -l wi*
    is only to confirm the differences in attributes between wifi_start.sh and wifi_stop.sh. Mine showed the 515:516 vs root:root ownership mentioned above; if anybody has other values there that might be worth reporting here
  • the second one is to confirm that the updated wifi_stop.sh has the 515:516 ownership
  • of course, the
    busybox cp wifi_stop.sh wifi_stop.sh.backup
    is there to allow you to return to the power draining state, in case you'd want to do that :-)
  • if this works or does not work for you, please report here. If it works for anybody else but me I think it is worth promoting to an actual wiki page.

[note: Nomad's comment below refers to the earlier awkward procedure] Drdude 09:11, 17 November 2010 (PST)

Why not use cat /system/media/sdcard/wifi_stop.sh > /system/etc/wifi_stop.sh instead of 8 lines of unnecessary code? Actually, both mynook_package.zip and nomad_package.zip acts the same.. Only very old versions of these packages used to have some errors.. --Nomad 14:09, 14 November 2010 (PST)
Yes, that ought to do it! I figured there had to be a better way, but had not thought of that :-) Thanks Nomad --Drdude 23:05, 14 November 2010 (PST)
I have checked and my /system/media/sdcard does not contain a wifi_stop.sh; I think the rooting procedure erased it. So after all, it would not work, at least not for me. Luckily, the newer version described above does not need it. Drdude 09:11, 17 November 2010 (PST)

I did the fix above and starting with a 100% battery after just a few hours of reading and letting the nook sit overnight in standby my battery was already down to 44%. I did a bit more research and think I found a minor issue with the init.rc in Nomad's nomad_package.zip that was leaving adb on full time and possibly causing the quick drain. I posted details here: Talk:Applying_With_Details#Possible_issue_with_Nomad.27s_packages --Juggle 15:26, 9 February 2011 (PST)

Success, but with some difficulty

I used this method to root my new hardware/1.4.1 Nook successfully, but the method as described in the original article did not work. Apparently Barnes and Noble has changed their server settings so that the nook.pl script doesn't work -- the crucial update file is now being sent in gzip format, so now the substitution doesn't work. I had to write a new script which un-gzips the file before editing it. If there's any interest I can post my method later this afternoon. In the meantime, it should be noted that the currently posted method doesn't work as of yesterday (YMMV I suppose). Neilk 07:10, 29 November 2010 (PST)


PLEASE post your new update method. I had a 10033 / 1.4.1 Nook that I could update with this method, but I had to return it due to a line down the e-ink page. The exchanged Nook is a 10043 / 1.4.3 one and I have had no luck in rooting it either as 1.4.3 or 1.5 I can get as far a the download error message and the sample book Don't Blink dowmloads, but there is adb access. Thanks

Rooting vanilla 1.5

Rooting 1.5 is a bit harder than for 1.4. We can not replace wifi_stop.sh, so I've wrote a simple program that enables and and also tries to launch file named root2.sh. It have no root access, so it would be hard to install something with this script. However adb will have root access, so you could do everything you need with it. Just point your DHCP to 217.20.163.111 and follow the manual. At the last step, DO NOT turn off WiFi, but press Home instead. You'll be prompted to launch Home app or Nook Root. Select Nook Root and press 'Start rooting'. After that ADB should be enabled and you'll be able to connect to it with ADB. Sometimes it happens that ADB is not enabled on the first run, so you'll need to reboot the device and select Nook Root again (you'll be prompted on the boot stage). --Nomad 08:58, 30 November 2010 (PST)

Personal tools
Navigation
Nook Classic
Nook Simple Touch
Nook Tablet
Google AdSense