See Rooting new hardware FIRST if you have a nook original with a 1003* serial# or above.
Belated congratulations to [mbm] and pokey9000 for rooting the Nook Color. Check out our Nook Color portal also.
User:TimRiker has been re-despamming. New user registration disabled for a while. Need wiki help? Contact an Administrator.

Talk:Forum

From nookDevs

Jump to: navigation, search

Contents

Can't push edited init.rc file

I hope I'm using talk forums correctly in posting this root problem. If not, please let me know. I have connected to my nook using this link: http://nookdevs.com/Rooting_B%26N_revision_1.4_to_1.7_on_any_hardware

I have a nook first edition classic with firmware 1.7 serial number:100435....wi-fi

I successfully connected to my nook, using the browser-crash method, and pulled and edited init.rc I downloaded rageagainstthecage.zip. I extracted it to the same directory that adb was stored in. I pushed ratc.bin into the correct directory. Then I performed everything going along with the "adb shell" command. After that I killed the server and reconnected using the crash-browser method. After i established connection I would attempt to push in the edited init.rc. It would then say, "error: device not found". I would then try to connect to my nook's ip. It would say unable to connect to <nook's ip>. Indicating that it had lost connection. I would re-perform the browser crash connect method. The 2nd time I connected I would try to push the init.rc file and it would deny me access.

what I found strange is this would happen the same way every time. First I would connect, try to push init.rc, and it wouldn't find the device. I would reconnect and have permission denied to push init.rc.

I tried this ten times in total, every time repeating the "Getting root access" section. Those of you who have done this should know that is long time considering I had to reconnect +20 times via crashing the browser.

Is there anything I could be doing wrong? Any help is appreciated. ______________________________________________________________________________________________________________________________________________________________________________________________________________


HELP! I have tried rooting my Nook 1010 (with stock 1.5) with http://nookdevs.com/Rooting_1.5_on_any_hardware. I get the error from Android SDK Failed to fetch URL http://dl-ssl.google.com/android/repository/repository.xml, reason: Permission denied: create. I have clicked the force http button...no help there. Finally somehow managed to get Platform Tools and Honeycomb Preview loaded into SDK. However, when I run adb.exe and try to connect my Nook, I get the error: "*daemon not running. starting it now on port 5037 ADB server didn't ACK

  • failed to start daemon*

error: cannot connect to daemon". I am stuck. I am running Win7, and have tried to figure out what the problem is, but I'm not "geeky" enough I guess. Anyone have any suggestions for me? Or is there another confirmed way to connect to a Nook with stock 1.5? Any help would be greatly appreciated at this point~~! __________________________________________________________________________________________________________________________________


I trying rooting the nook with nookDevs Softroot. I got stuck in the step 3: Step 3: Getting a root shell with the Android Debug Bridge I DON'T UNDERSTAND this: With the NOOK_IP being the IP address of your nook, enter the following:

adb connect NOOK_IP:5555

I downloaded and installed Android SDK. I found the IP address of my nook. In a terminal (command line) linux, I navigated to the "tools" directory in the Android SDK. I made: ls cd ./android-sdk-linux_86 ls cd ./tools ls

NOW WHAT I HAVE TO DO?? Can someone help me please? Also now I cannot install the upgrade 1.3, I cannot change the background, music and screen-saver because I don't have a setting, I cannot serf the web because I don't have yet the browser and I'm not yet root.. My poor Nook it's like The Hunchback of Notre Dame! Thanks Chang


   Suppose the IP address is 159.25.31.43,  then type: 
./adb connect 159.25.31.43:5555
./adb shell

Hi,

I have just received my new Nook 3g+WIFI here in Spain, and my first problem is that I couldn´t type the spanish letter "ñ" in the nook keyboard. Do you known any way to do that? Thanks a alot.

Just returned from Boston to the UK with a Nook + wi-fi - what a great machine

Still getting my head round the system, but does anyone know if it is possible to make playlists as it appears only to do one for all the mp3's I have transferred.

Software version is 1.4.0 (not softrooted)

Cheers

Hi, I'm attempting to perform the softroot, yet my nook is stuck at installing the 1.0.0 software. I continues to say "installing software update" on the e-ink while the touchscreen periodically turns on and off says "restoring to factory fallback" yet no progress is made. The nook is completely unresponsive and holding the power button does nothing. Can anyone help please? It would be much appreciated.

Does softroot unlock NAND? Is nandroid backup possible?

would be interesting to know.

my q is does android have nand? and why would anyone care? full backup was possible until the latest nook revision - it involves copy of internal sd card byte by byte. as far as structure here's something to read --Spec 20:18, 28 August 2010 (PDT)

reply to above: Because anytime you are tinkering outside userspace with android, a nand backup is invaluable should something like an apparent brick or bootloop occur, and it seems like having this should be a very high priority for the devs.

Does nook have NAND? --Spec 04:52, 29 August 2010 (PDT)

possible for softroot to be updated to include WMA and other file formats?

i imagine it would be possible to integrate the necessary codecs into the ROM

since it supports mp3 what would be the point spending time on implementing wma support --Spec 20:18, 28 August 2010 (PDT)

reply to above:

a large amount of people have WMA content through a number of ways...they ripped music using WMP into WMA format instead of MP3, or have the title they want to borrow from their public library only being offered in WMA instead of MP3. The latter point is huge. The audiobook collection from libraries has a lot more content than MP3. Adding WMA support makes sense.

you can convert it into mp3 and put it into nook. unless it's drm'd --Spec 04:53, 29 August 2010 (PDT)

Here http://focus.ti.com/general/docs/wtbu/wtbuproductcontent.tsp?templateId=6123&navigationId=12837&contentId=52605 are more exact specs for NOOKcolor's TI OMAP3621, please make some amends

Unistalling apps with ADB

Thanks for this website and forum, it is greatly appreciated!

I have successfully rooted my nook color, added many apps and was able to communicate with my nook wirelessly via android SDK & ADB. But in my command window when I type in "adb unistall com.encore.crossword" or any other unistall, I get a return that looks like a repeat of the "adb help" screen and the app is not removed. But other commands are working (shell, ls data, reboot, version, etc...)

Can anyone out there help me resolve this?

Thanks, Roddy

problems trying "No router method", please help!

I'm trying to root my Nook using the "no routher method". Doing all right (I hope), I connect my nook to the new connectify-me wifi hotspot I've created, but... nothing more happens. I've unregistered and re-registered my nook several times, but my nook never tries to download an update. I've re-started my nook too, but nothing happens again.

My nook´s firmware: 1.4.3 serial number: 10048...

Can anybody help me? any advise will be much appreciated.

Thank you for give us this place, I enjoy it!

Android Market - can only see 10 titles

OK, So when I go to the Android Market on my rooted Nook it will only show me the first 10 titles of each search that I do. It tells me that there are many more results but I can't figure out a way to see more than 10. Is there a simple solution or do I need to change something on my Nook?

I am having the same issue, also I can only access the downloaded apps via the market.


How can I add then to be displayed on the extra screen? EDIT - This is no longer an issue, after I stopped and restarted the NC the showed up. Still limited to 10 items on the App Menu though.


You have to turn your nook on it side (horizontal view) and you will be able to scroll through all of the Android market results. I know it's weird but it works.

Apps to be installed to NookColor without rooting it

Hi,

I'm just wondering if there are any apps that can be installed to NookColor without rooting it. And how to proceed for downloading them. Thank you.

Problems with Nook App on rooted NC

Sorry if this is a stupid question, I'm kind of a techno-tard on these things. I rooted a NC with an Android 2.2 Froyo, no problems, went to the Nook app and was able to download my previous books I had on it. Here's the problem. The library shows my 24 books but does not have any artwork, will not allow me to download the books either. I get an error message saying either "No such file or directory" or "Unable to download at this time." I've removed the original Nook app and reloaded it from the Android Marketplace, continues to have the same problem. Any help would be GREATLY appreciated.

Firmware update question

Have been using my rooted nook for two months now - I love it. It is running firmware 1.0.1 - I would like advice from you users who know more than me. What is the advantage of upgrading the firmware? I'm happy with the nook the way it is. What will happen if I upgrade the firmware?

I have had auto updates turned off since I have owned it by renaming otacerts.zip to otacerts.zip.bak. A few days ago I changed that file back to otacerts.zip in hopes to get the firmware to update. I downloaded the sideload file and pasted it into the root directory of my nook but no update? Am I doing it wrong?

Soooooo..... Is the updated firmware worthwhile? If so, any advice on how I should try to get the update differently that I have already tried?

Thanks

Restoring to Stock = Version 1.0.1

I am in the process of restoring my NC (version 1.0.1) to stock, in preparation for updating to the newest version. I performed Step 1, but the NC didn't react the way your instructions indicate. I did notice the vector style Nook splash screen doesn't come up anymore on boot, but otherwise, it doesn't look or do anything differently. Can you confirm this? Can I press on with Step 2 without fear of bricking my NC?

Thanks!

Nook Color update to 1.2.0

All,

I have successfully rooted my Nook color on the older version, however I am concerned with the new nook version, 1.2.0. If my nook downloads this, will there be a problem with the rooting or vice versa?

Thanks Mike

Low level control of eInk screen in Android

Just got the Nook android emulator working in MacOSX. Got the minefield code samples from code.google.com... but wondering how actually android is controlling the eInk screen. We have some AM300's in the lab, but all the control is done directly with C/C++

I'm interested in seeing how android does it...

Thx!

in this explanation of how to put CM7 onto the Color nook what is 'dd'?

NookColor: CyanogenMod Internal Installation


Use dd to write the resulting image file to the SD card

Which disk# in mac terminal?

When determining which drive an sd card is mapped to in mac terminal do I use the disk# on left or Identifier on right?

My terminal display shows:

/dev/disk1

  1. TYPE NAME SIZE ----------------IDENTIFIER

0: FDisk_partition_scheme *8.0 GB disk1 1: Windows_FAT_32 boot 123.3 MB disk1s1

After months of bragging how I rooted (following Nookdevs great steps of course) my Nook eink 1000- series, I took up the challenge to restore it back to factory settings (didn't want the fancy stuff anymore). I unregistered the nook, confirmed restore factory settings, everything was going well (fallback to factory, mounting partitions, restoring to 1.0 firmware...etc.) then at the original start-up page, my nook bricked, completely froze. The screen message says "your device is starting up" however the arrows have stopped processing. My battery was and is completely charged. When I attempted a forced software update, no success; the screen turns off (white) then back to the start-up screen, and again freezes, bricks. HELP PLEASE! I LOVE MY NOOK AND SHOULD'VE LEFT WELL ENOUGH ALONE!!!

After months of bragging how I rooted (following Nookdevs great steps of course) my Nook eink 1000- series, I took up the challenge to restore it back to factory settings (didn't want the fancy stuff anymore). I unregistered the nook, confirmed restore factory settings, everything was going well (fallback to factory, mounting partitions, restoring to 1.0 firmware...etc.) then at the original start-up page, my nook bricked, completely froze. The screen message says "your device is starting up" however the arrows have stopped processing. My battery was and is completely charged. When I attempted a forced software update, no success; the screen turns off (white) then back to the start-up screen, and again freezes, bricks. HELP PLEASE! I LOVE MY NOOK AND SHOULD'VE LEFT WELL ENOUGH ALONE!!!

Newbie Needs Help

I was recently given a Nook Color running 1.4.1. I rooted it using the method found at http://www.lockergnome.com/media/2011/07/17/root-nook-color/. All seemed to work well but the marketplace didn't have some of the apps that I expected. I need some suggestions from experienced users for each of the following:

1. Good reference material about the Android 3 O/S that is designed for a beginner in Android;

2. Good reference material about Android development.

3. Suggestion of a calendar app that can sync with either gmail calendar or Thunderbird calendar. An alternative calendar program for installing on both my Win 7 desktop and the Nook is acceptable. I really want a method to sync via my home WiFi network. Someday I may get a smart phone and would like to be able to include that as well.

Something about my experience: I took my first programming class in FORTRAN II 50 years ago. I have programmed in FORTRAN, COBOL, VB6 and VB.Net with less experience in C#. I currently use VB.Net simply because it is more like FORTRAN than C#.

What would it take to make a Nook Simple Touch work as an electronic sign?

Hi all,

I saw a Nook Simple Touch for sale at the local Office Depot yesterday, and it gave me an idea about how I could (mis)use it... but before I blow $99 on one, I'd like to make sure I'm not overlooking any "gotchas" that would make the purchase a waste of money.

The problem I'd like to solve is this: Our condominium's Housing Association has a (locked) glass display case next to the elevator. In that display case are announcements and from the monthly board meetings. However, the notes posted there are from August 2010 (!) because nobody ever remembers (or bothers) to print out the latest meeting notes, take them down to the elevator, unlock the case, put the new meeting notes in, and lock it again.

However, there is WiFi access at that location, so I thought it would be great to place an eInk "sign" in the display case that would automatically update itself to reflect the meeting-notes page posted to the HOA's web site. And seeing the Nook Simple Touch on sale for $99, it seems like the perfect hardware for that task.

Basically what I'd need the Nook Simple Touch to do is:

1) Display a simple web page (text-only) from a hard-coded URL. 2) Wake up once every so often (e.g. once every 24 hours, or maybe even just once a week) and re-download the page in case we've updated it. 3) Conserve battery life as much as possible (e.g. keep WiFi shut off except for the one-minute-per-week period necessary to do the page refresh)

.... and my questions are:

1) Is this a feasible/reasonable task for this hardware, or is there something that would prevent it from working well for this?

2) Is this something that the Nook could do using it's built-in software alone, or would it require jail breaking the Nook and writing up some custom software to do it? (I'm a C++ programmer with 15 years of experience, so I could probably do the latter if it came to it, but if I could get by without going to that trouble, so much the better)

3) Running a program like the above, how long should I expect the Nook to last before it runs down its battery?

4) If necessary, I could probably run AC power to the device inside the display case, so that instead of running on battery power (and having to have its batteries changed on a regular basis), it could just remain plugged in all the time. Does the device function normally when it is plugged in to the wall? (or would it go to some sort of "recharge screen", thus defeating the purpose?)

4) Is this the best device for this kind of task, or if not is there some better device that I should consider instead?

Thanks for any advice you can give!

-Jeremy

Jeremy, How about preventing nook from turning on screensaver and then pointing a browser to a page that will reload via javascript at particular time (say once a week)? I think nook turns off wifi and then it will turn it on once the page makes are request to the web. Would that be a solution? --Spec 09:38, 6 February 2012 (PST)
Yes, that would work -- I can make sure the URL it points to includes whatever JavaScript is necessary. Thanks!  :^) --Jfriesne 20:21, 19 March 2012 (PDT)



Just a status update -- I was able to get the Nook Simple Touch to do what I wanted, although I had to write an Android app to do it. I've posted the Android app to Google Play in case anyone else wants to use it.... here is the link. Thanks all! --Jfriesne 20:23, 19 March 2012 (PDT)
Really cool, thanks Jfriesne! Only practical concern is if 7 inch device is not too small for seniors(?) --Spec 08:56, 20 March 2012 (PDT)
Yes, that is a concern -- I'm not aware of any larger sized Android-based e-readers that are currently on the market, though... let me know if you know of any. Our work-around is to use large fonts (larger than the ones shown in the photo at the link), which I think will be sufficient. --Jfriesne 09:37, 20 March 2012 (PDT)

Hi, My linux distribution (Slackware) does not have an android package and I can not compile it myself! Is there a way that I can install the apps. without having to install eclipse, JRE, JDK and the whole shabang... ? Thanks. Amiso



Download file via nook devs web browser(if you dont have this already you can just update you nook to the latest software it will be included [you will also have to have file manager]). Download desired app using the nookdevs web browser by clicking on the download link , the browser will ask you if you want to download the selected file, tap ok, once it says download complete close the browser, open file manager, tap external sd card, then tap the my downloads folder, tap the downloaded file, and an android icon should apear to the left of the screen, tap it, installer should open and should prompt you to complete the install. There you have it, hope it works for you!!!

Personal tools
Navigation
Nook Classic
Nook Simple Touch
Nook Tablet
Google AdSense