See Rooting new hardware FIRST if you have a nook original with a 1003* serial# or above.
Belated congratulations to [mbm] and pokey9000 for rooting the Nook Color. Check out our Nook Color portal also.
User:TimRiker has been re-despamming. New user registration disabled for a while. Need wiki help? Contact an Administrator.

Forum

From nookDevs

Jump to: navigation, search

Contents

inverted colors e-reader apps?

Are there any epub readers that can be installed on the nook 1st edition that have an "inverted colors option" (ie, black page, white text)? Thank you




Running ANY Android app on Nook Classic

http://code.google.com/p/virtual-touchpad We need to develop that app to be able to run any Android app for 1.5 beeing able to click anywhere in the eInk screen on Nook Classic. Using a virtual touchpad. Help in develop is mandatory. --Mija 01:56, 5 July 2011 (PDT)

Nook Boot Screen

Hi all, I have a few rooted Nook Colors (some 1.1, some 1.2) and find the 'Barnes and Noble' and 'Enjoy the power of reading' boot screens annoying - is there any way to suppress these?

Thanks for any help, Mikei 05:14, 15 June 2011 (PDT)

There are three different locations for branding screens on the Nook Simple Touch, maybe this will help you with your Color: Nook Simple Touch screensaver Renate 05:32, 17 January 2012 (PST)

Other Issues

So I'm having some trouble rooting my nook classic. I connect to it. Then get root access, but when I kill the server and try to reconnect to it, I can never complete that step leading up to pushing the init.rc file. Is this common or am I doing something wrong? Has anyone else ran into this problem?



ok I have a Nook running V1.5.0 software and serial 1010 I am able to crash nook Via web page and adb connect I am also able to pull init.rc First problem when i open on note pad it is one long string of text not in line order I read all the text and found a section (service adbd /sbin/adbd disabled) and changed to enable I followed the next steps in shell all no problems Crash nook again through web page and adb push inti.rc says successful 299kbs reboot nook and no change still unable to adb. any suggestions please


Read more: http://nookdevs.com/User_talk:Clarkma7#ixzz1LTDwe4Nt Under Creative Commons License: Attribution Non-Commercial Share AlikeGot a texting app running on the nook classic havent tried texting yet. But i will test it out and give you the results and post the link as soon as time permits


Mivht be able to get it on The nc wish i had one But it probably wont work on the nook classic with out a lot of remodeling if your still interested about the link post something here and ill send it to you



Security of rooted/soft-rooted nook classic I've been trying to get some answers on the security of a rooted nook, but no one seems to know or want to answer. I need to know if the password feature is still available on a rooted nook classic or if there is any security feature still enabled. Any one still use the password feature on a rooted nook?

-masterninja01



Yes it does you have nothing to wory. just about all the barnes and noble stuff that your used to will still be on There


  I have a classic rooted and the option is still there, I haven't tried it, I'll give it a go today--Radar92 06:50, 21 April 2011 (PDT)
  I enabled it and it worked fine. --Radar92 16:18, 21 April 2011 (PDT)

________________________


I just bought a refurbished nook hoping it would be old hardware but to my surprise it was 10051, and when 'falling back' it falls back to 1.5.0. You have been warned! I will try to get it to 1.4.1 and update the wiki when I successfully root it.

-linuxwil

___ __ ___

hey i tried to install the nook devs 2.5.1 on my 1.0.0 nook using my micro sdhc 4g memory card . i followed step #8, and it says on the eink screen that its installing an update but the loading bar on the touch screen only gets to where

it says checking for updates, then it just reboots, whats going wrong   ----

--- -





I'm a complete newb here and in no way much of a techie, but found many sites with instructions that seemed simple enough on rooting my NC. I had the latest update from B&N

before rooting and rooted via an SD card using autorooter. I had no problems and installed a few apps (angry birds and some other games).  I wanted to figure out how to get the game icons on the home page and came across instructions for installing clockwordmod recovery from this link (http://www.youtube.com/watch?v=WOLaYp_P9xI).  This was the same guy who did the you tube video for the noot rook and it worked well so I figured it would be easy.  Well, something was wrong with my SD card (it was only showing about 39MB of space even though it was a 4GB card).  When I deleted things I must've messed it up somehow.  If anyone happens to know how to fix that it would be lovely to know too.  But anyhoo, I realized this when I was trying to go through the backup process, so I pulled out the SD card and switched it with another one.  It seemed to finish everything up fine.  However, when I got to the "reboot now" section of the instructions, it didn't work.  Now it's stuck in some kind of loop.  If I leave it alone it just sits on the CWM Recovery Memory screen.  I have to unplug it from the wall to even get it to completely power off without just rebooting.  Anytime I try to power it off it just reboots again right back to the same menu.  Someone on this site gave me some instructions and you can see our posts here http://www.androidtablets.net/forum/nook-color-technical/6386-how-installing-using-clockworkmod-rom-manager-nandroid-backup-custom-kernels-50.html  I'm getting slow responses here and thought I'd post elsewhere too.  I'm freaking out that I've totally messed up my NC.  PLEASE HELP!!  (Oh and if you could please make it as 1st grade level for me as possible I'd really appreciate it ;-))

Supergirl9801


How to re-install YouTube. 25 Mar 2011 OK, I followed one set of directions after Rooting my NC to get YouTube to work. It said to un-install and re-install. The un-install worked fine. I cannot figure how to re-install. I wish I had read the other set of Rooting instructions which said not to uninstall YouTube but to erase user data. Too late for me. The m.google.com/youtube?dc=mqc_home site will not recognize the NC so I cannot DL.

OK, with a bit of snooping around I found a post here http://forum.androidcentral.com/barnes-noble-nook-color/51858-resolved-installing-apks-resolved.html In the market download astro file manager. In astro go to the menu>app manager. Check the box next to the YouTube app then tap backup at the top of the screen. After backing it up, uninstall the app (nook color tools or astro will work) then use astro app manager to reinstall from the SD card. Worked like a champ.

Greg



A newbie wants to know: The "How To Do It" Pre-requisites recommends using a class 6 microSD card. I take it this is a precaution and not a necessity? Has anyone used a non-class 6 card?

FYI, I used some old microSD card I had laying around. It worked fine. It will either read the card on not. Pretty safe.


How can I upload files into nook emulator?


I have a couple dumb questions: 1) It seems that the nookcolor has a 1024x600 screen, and hardware scaling from 854x480...

Is this because Android doesn't support the big screen yet?

When android does support it, will the screen look better? (It doesn't look bad now)

Or am I just totally confused here - does the nc use the whole resolution?

2) how can I get my .epub books I bought and downloaded from baen.com onto the 'Home' screen?

I read through the user guide several times and tried stuff, and can't get it to go.

Thanks, Tonkabot



Looking for help with Unistalling apps!

Thanks for this website and forum, it is greatly appreciated!

I have successfully rooted my nook color, added many apps and was able to communicate with my nook wirelessly via android SDK & ADB. But in my command window when I type in "adb unistall com.encore.crossword" or any other unistall, I get a return that looks like a repeat of the "adb help" screen and the app is not removed. But other commands are working (shell, ls data, reboot, version, etc...)

Can anyone out there help me resolve this?

Thanks, Roddy


How can I use China_Mobile SIM card? There is the China_Mobile date in telephony.db,but I still can't visit websites.


New Hardware?

Install bravo_update.dat from sd.

1. Hold the power until your e-ink screen goes off.

2. Press and hold the "<" button on the right side of the nook, and then press and release the power button, while continuing to hold the "<" button.

3. You can release "<" once a screen appears indicating that your device is updating. Wait through the entire process and when you see a launcher screen, reboot once more.

Forcing Software Update

  • Turn off nook
  • Turn it on
  • Quickly hold 2 buttons on either side (not all 4 as previously said)
  • A screen will appear on the eInk display that says updating and the lower screen will show "Mounting partitions" and then "Checking for updates"

Neither of the routines above work for me. After I press the power button my screen goes black and stays black until I get the starting nook screen. I have new 10038 hardware.

Can anyone confirm that these keypresses work with new hardware? Is there a way to load unsigned bravo_update.dat files with new hardware?


NookSDK for NookColor they announced it here--> http://connect.nookdeveloper.com/t5/NOOKdeveloper-Blog/NOOKdeveloper-and-NOOK-SDK-1-0-Launched/ba-p/23 --Tanelorn 19:00, 3 December 2010

B&N Firmware 1.5.0 Heads up: B&N apparently is pushing this down via wifi. Sorry if that's old news to everyone else, but I was dumb enough to leave airplane mode off. Not bricked, but my battery is draining crazily while asleep. Gotta fix this thing, as soon as I've got it charged enough to change the screen... --AnjeTheNerd 19:00, 1 December 2010 (PST)


Anyone here with the original Android Nook app? I can not access the app on the Android market due to geographical restrictions - a link to the .apk would be highly appreciated! Thanks, resride2k Update: I got it - using VPN to get a US IP address _AND_ going to flight mode to deactivate the SIM card did the job... before I always tried VPN only with no success.


Will this team be working on rooting the Nook Color? -- XDA Devs are working on it here: http://forum.xda-developers.com/showthread.php?t=825174


Does anyone have any information on where I can download the pandora.apk? I have tried from this site, but keep getting a HTTP 403 error and am unable to find it anywhere else. The help would be appreciated! Thanks.


Video of custom bookshelf library app: http://www.youtube.com/watch?v=bDYsT-F6XVc --Nomad 08:19, 4 November 2010 (PDT)


All, I am hoping someone has seen this. Wifi on my rooted nook quit working. --- later update, I used the 6*12 reset method, got the wifi working again, rerooted and dumped the apps back on. Thanks to Nomad, and having the dd-wrt on my router, this goes quick. Best of all, I didn't lose any books.--Crandallbk 21:45, 2 November 2010 (PDT)


I have been loving my softroot, but have trouble with trook. I want to view the lifehacker and gizmodo feeds (among others) but have been avoiding calibre because i have the 3g nook, and dont want to rely on syncing it with the computer. the problem is that the site appears in the e-ink window and is skewed off to the side so that 15% of the text is not visible. ive also been playing with greader, which still doesnt have any feature allowing the full article to be seen. is there any solution for these issues besides calibre?


I hope someone can help. I wanted to get my rooted Nook back to the base root of 2.4.1 so I tried reinstalling the 2.4.1 update. Now my Nook boots to a black screen with "Sorry. Activity Launcher (in application Launcher) is not responding." I can't do anything with it. It doesn't show up as drives on my computer anymore, I can't get adb to work (or just have no clue what I am doing and there is no good explanation on this page that I can find), and trying to do another update has not helped. I have even tried to go back to official BN 1.0.0 firmware with no luck. Can anyone help me get it working agian or am I out of luck? --Icthusman1 18:22, 26 October 2010 (PDT)

Well -- I managed to trigger a fallback on a 2.4.1 by using a technique I read somewhere:
- Repeat this 6 times and then if it works it will boot and start the failback proceedure on the 7th boot.
 1. The second the black screen shows, press and hold the power button for 12 seconds and release.  
 2. Wait 12 seconds. 
 3. Press and release power button.
 

Good luck. --Randomizer 19:43, 26 October 2010 (PDT)

No luck. I have been trying for a while and it has not done anything different yet. I assume the black screen you are referring to is the one I mentioned I see after it fully finishes booting and not when the screen flashes black at the start of the booting process?

--Icthusman1 10:31, 27 October 2010 (PDT)

Nevermind, it's the initial black screen flash. Hopefully it will work now once the failback process finishes. --Icthusman1 10:49, 27 October 2010 (PDT)

Woot!! Thank you Randomizer, that seems to have done the trick. Back to Factory settings and it seems to be working again. You are my new best friend (after my Nook of course). --Icthusman1 10:55, 27 October 2010 (PDT)

Glad it worked for you. I lost most a a night's sleep when it happened to me. --Randomizer 11:29, 27 October 2010 (PDT)

No discussion of the v1.5 software coming out soon? Anyone got a peek yet or are we just needing to wait until it is officially out and then someone can tear into it? --BigBadger 09:57, 22 October 2010 (PDT)


Amazon recently released the Kindle Development Kit for devs to make their own apps; maybe BN will let us make apps without rooting soon.


i have software 1.4.0 with serial 100312

which rooting method should i follow?

The serial doesn't matter. If your nook is one of the newer models then it comes with 1.4.1 or 1.4.2. Otherwise it would not boot. If your device runs on 1.4.0 you got a unit with the older (better) hardware, therefore it can run any firmware version from 1.0 to 1.4, therefore you can use the "classic" softrooting method. --Dominik 03:38, 20 October 2010 (PDT)
Thanks got it up and running. Now if i could just figure out how to make the lifehacker feed (trook) fit on the e-ink display instead of being pushed to the side. --Jewnersey 21:15, 25 October 2010 (PDT)
Is that for certain? I have a nook with 1.4.0, but the serial number is 10034, which seems unexpectedly high for still having 1.4.0 firmware. I'd disassemble it to see if it has an SD card, but they seem to have switched to star-head screws, and I don't have any star wrenches. --Sweng123 08:50, 4 November 2010 (PDT)

Android Z code interpreter

Is anyone interested in making one work on a Nook???

I think it would be a great app to have!


Can any one tell me the wifi chip model in new wifi nook?


Does anyone truly like the design of this site? Don't get me wrong...the content is great, yet the design and general idea sucks.

A wiki site is great for some features...but this kind of forum sucks.

Anyone agree? disagree?

Maybe they can start a github and host the wiki and forums there.
You got mr forum as alternative. lot of people here are there too. --Spec 13:44, 6 October 2010 (PDT)
www.phpbb.com is very good and easy to install, is possible to use forum.nookdevs.com or nookdevs.com/forum, etc. of course, the creation of the forum can accelerate the development of ideas. Is possible to do this soon? I could create one in my domain, but is not the same thing. --dark_steybow
creation of mulitple forum can decelerate the development. What's wrong with using mobileread forum? --Spec 05:53, 9 October 2010 (PDT)
certainly nothing, I have not suggest the creation of various forums, maybe my bad english caused the misunderstanding. actually my suggestion is to create a forum dedicated to this development independently, with an owner that provides constant backup to avoid loss of information (with problems or censorship). I don't know mobileread forum very well but is possible they delete some topics or replys?. I say this because I know projects that have suffered a great loss when the forum has been disabled for no apparent reason. imagine something like http://mynook.ru/ with news, wiki, forum, etc. and with good layout and easy to manipulate (sorry but I prefer WYSIWYG). dark_steybow 15:24, 9 October 2010 (GMT -3)

--I have a largely unused forum at hackerfoundry that you guys are welcome to use. There's already a community there hacking the didj player.


Guys, is there any instruction on how to build kernel for Nook? I have tried to use Android NDK, but with no success.

I think you build it on regular x86 linux and target arm. There's a github repository mentioned here, sounds like a good place to start a search. --Spec 12:59, 6 October 2010 (PDT)
Yep, I was using sources from JesusFreke git. I have compiled it with Android NDK, packed the compiled zImage into bravo_update.dat and started the Nook update process. Accidentaly it stopped and Nook has performed fallback to factory default firmware. --Vlad123
After doing some googling I found out that I need to build uImage instead of zImage, but it is still not working. Another option I'm going to try is to use another toolchain. --Vlad123


Just wondering if any work is being done to softroot the new hardware? I just picked up a 3G Nook with Software Version 1.4.2 and serial #10037. Thanks and keep up the good work! ---eridium Oct 6, 2010



Could someone please help, i just tried to add AntiVirus, but it didn't download, so i whent to its site and downloaded their apk and then it screwed the non-touch-screen part of my nook up, it is frozen and i really need help. -144Mitch420 5/10/10

Can you do hard reboot by holding the power button on top for 10 seconds and then turn it back on? My recommendation is not to install this "antivirus" because there are no real viruses for nook or android. --Spec 17:33, 5 October 2010 (PDT)

Could someone please give a short rundown of the commands available on WebNookDev,0.0.9. The ˄˅, ˂ ˃, ˂ seem to have inconsistent effects. It's probably situation dependent, but I'm not getting it.--Donob10 07:06, 22 September 2010 (PDT)


Where can I find documentation for functionality of Nook File Manager. Specifically, what is the "Media Player" option good for? This appears along with a bunch of other functions available when opening an HTML document with File Manager. Clicking it opens what appears to be a video screen in the left half of the touchscreen. Trying to open a video file results in the error "No Viewer Found",

Documentation is a slick problem for all the apps here, and there's a lot of "easter eggs" in those apps. I hope this comment doesn't stop developers from developing, instead they'll start putting 2-3 lines of explanations what's new and how to use it. --Spec 07:12, 17 September 2010 (PDT)

Hey, wondering if anyone has considered porting the PSFreedom to the nook? Is it even possible. Which USB chip is in the nook?


Hey Koolkat67, how did you change your Nook from the default of ADB over USB to ADB over WIFI? I'd like to connect via WIFI instead. Post here or send information to nookdevs@tekforte.com

Thanks, haldog

Haldog, I actually never did. I saw steps somewhere to do it; I cant seem to find them now. I just ended up getting used to the USB thing. I liked the Wifi better cuz you didn't need to install the driver or need a cable. If there is a way to do both, that would be cool.--koolkat67 15:33, 9 September 2010 (PDT)


Nook works with Google App Inventor! Download Google App Inventor in: http://appinventor.googlelabs.com Nook ADB USB driver: http://rapidshare.com/files/413058007/usb_driver_r03-windows_nook.zip Requires Java see App Inventor workink on Nook: img0163g.jpg I can use App Inventor in my pc and see the modifications live in the Nook screen, but i don't know do nothing in this thing. lol I think it's more useful for programers

Good luck. How did you get app inventor to recognize the nook? I keep getting phone not found.


I'm having the same black home screen issue after softrooting to 2.4.1. I was able to go back to 1.0.0, then again to 2.4.1 using a freshly downloaded image, but after about a day I'm back to the black home screen. I did not install or update and apps, just what was included with 2.4.1 Any ideas? I have ADB access and tried removing and adding back ru.launcher. ---Technocrats 17:01, 3 September 2010 (PDT)


Most of the time after I detached my Nook from the computer and try to Stop ADB the Wifi Locker locks up...anyone else seeing this?--koolkat67 11:54, 3 September 2010 (PDT)


I have the same experience as below: serial nu 1002, softrooted in August and worked fine. When I tried to update ru.launcher to get icon functionality, once installed, the screen goes blank. I had to resoftboot to get any functionality back. I've tried this twice with the same result. Tarthol 3.09.2010



I updated ru.launcher on my serial 1002 FW 1.4.0 thru the Nookmarket app. yesterday. The launcher would not start and left both screens blank (with the "Home" header on the eink). After a while the "Sorry! Activity Launcher (in Application Launcher) is not responding." error message appered. I had to uninstall and reinstall the old ru.launcher thru ADB. Hebo, 28.08.2010


I keep running into an issue installing applications on my Nook. It seems that many apps give me "INSTALL_FAILED_UPDATE_INCOMPATIBLE" or another error about certificates when using "adb install". NookMarket just tells me the application failed install or could not be installed on my phone. The strange part is that I sometimes can install these apps. It almost seems to be related to the order I am installing them in. In order to work around it, I have to re-softroot, but the problem always shows up again. Anyone have any ideas? --Mordenkainen 10:08, 26 August 2010 (EDT)

This could happen if the apps are built using different certificates. Most of the apps in code.google.com/p/nookdevs site are built using the same certificate. You should be able to upgrade them without issues. I have never seen this issue if the certificate is the same.

For example, the Trook app changed by craftycoder and the original Trook are built using different certs. You cannot upgrade that. You need to uninstall first.

When this happens, your only option probably is to uninstall the app and install again. You can uninstall in nookMarket by long-pressing on the app icon. Or use the appManager app or adb uninstall command. --Hari 07:49, 26 August 2010 (PDT)

Thanks! Does this apply to both the error messages I'm getting, or only the one for the Certificates? --Mordenkainen 08:55, 26 August 2010 (PDT)

I was thinking about this .apk signing thing. Hari, and others - do you think it's possible to build android projects (apk files) without any signing at all? To prevent these cases where you are forced to uninstall in order to install something else? This would be extremely useful, since every application on nookdevs is opensource, which means everyone who has knowledge in java can edit application and even fix some errors, and if the author is away, then he or she can build the new apk which would have no signatures, thus making it easier to install it.


I would like to request access to the nookapps project on googlecode, so I can edit the wiki file for nooklets, which contains several errors, those took me several hours to figure out how to fix, so I would like to share the information. Also, I can write some other tutorials regarding nooklets on the same wiki page, Here is the link: http://code.google.com/p/nookapps/wiki/NookletGuide http://code.google.com/p/nookapps/wiki/NookletSpecification

It would be really nice to edit those 2 pages. Thanks, --Atomix 09:59, 24 August 2010 (PDT)

Unless kbs returns, I doubt that will happen, I did see another person listed on that project, might be a good start to email them. --Poutine



Hi, I install Repligo Reader - http://www.cerience.com/ - (its a very good reader) in Nook and runs Ok, the problem is how to navegate without a "keyboard"? Can anyone helps me? Thanks.


Help needed - softrooted new Nook WiFI, serial 1002... booted, everything working great, added my WiFi point, turned off the device, took out SD card, put the back cover back, and there came problems When I press the button, it goes up to Your device is starting up line, the bottom sreen lights up, and it continues like that for ever. My longest attempt was to leave it for the night, around 7 hours - same. Tried draining and recharging the battery, taking the battery out, putting the sdcard back, connecting it to the PC (did't see it). The only operation that seem to do someting is restoring the original firmware, power button 6 times for 12 seconds. Then it gooes through all process of restoration and boots to the point when the icons on the bottom screen appear. After that it stops responding. In the top right corner of the bottom screen appear strange black artifacts. I tried that procedure several times, and once or twice the device hanged in a different position, with a message "Sorry! The process android process media has stopped unexpectedly. Please try again. Force close"

EDIT: Fixed! Removed the battery, waited more than an hour and connected to PC.


Just attempted to softroot to the latest 2.4.1 and after the update and a reboot I get a screensaver and amessage to press power to wake up my device. When I do so I get black screens and 'Home' on the taskbar. If I wait long enough, I see a message "Sorry! Activity Launcher (in Application Launcher) is not responding.". I can't get to the sd cards via USB. Can't connect via WiFi (of course). Was softrooted well before and had lots of apps installed. Device serial number begins with 1002... Thoughts? --BigBadger 20100817

EDIT: I was able to roll back to 1.4. Still wondering what went wrong.

Did you try to upgrade the ru.launcher via NookMarket? That caused this same black screen for me 2 days ago. --koolkat67 08:20, 18 August 2010 (PDT)

I probably had, sometime prior to attempting the softroot update (2.4.1). I wonder if the ru.Launcher is okay on 1.4 but not on 2.4.1.

How does one properly inser the username and timestamp here? --BigBadger 20100818

When you edit article you have a toolbar on top of the edit box. second icon on the right insert 2 hyphens and 4 tildes which, once the edit is saved, turns into signature. --Spec 11:43, 18 August 2010 (PDT)

Thanks much! --BigBadger 14:03, 18 August 2010 (PDT)


Having the same problem her; black screen and Home "sorry, activity launcher (in application launcher is not responding). Also build 1002 and 2.4.1 AND after installing ru.launcher. I am having problems going back to 1.4. Bigbadger; any advice? [user:maurizio|maurizio] 22:10 19-08-2010

I removed the external SD card and used another device to copy the 1.4 softroot to the root of the drive. Then placed SD card back in nook and forced update. At this point you might need to remove ru.Launcher. I then updated to 2.4.1. --BigBadger 21:10, 19 August 2010 (PDT)

Edit; FIXED. I probably did not hold the upper right button long enough. The firmware-update (or downgrade as you wish) therefore stopped, I think. After more than 15 tries and your advice it started updating. I put the 2.4.1 firmware back and must remember not to upgrade ru.launcher. Thanks top BigBadger for your help;) --Maurizio 23:47, 19 August 2010 (PDT)

Actually in previous versions of softroot instructions you were supposed to let go of the upper right button as soon as you see it's updating. I wonder if you weren't holding it TOO long. Just a thought --koolkat67 15:33, 20 August 2010 (PDT)


To the Writer of the Wifi Locker, it might be handy to have an option to timeout and shutdown the ADB. This is definitely one of the battery power eaters which most people might not realize. And sometimes you forget, leave it on and the next time you go to use your Nook its completely drained. Just a thought --koolkat67 11:56, 16 August 2010 (PDT)


The links to download the Antivirus App are not working. --koolkat67 11:53, 16 August 2010 (PDT)


Hey all, I just softrooted (Serial 1003, firmware 1.4.0) my nook wifi, and it's working just fine. One note, is that is continually uses battery power, even when in screensaver mode. Has anyone else experienced this? Any fixes?

-Noobtron5000 8/15/10

i have been facing this issue since i softrooted my nook. There is some problem with some of the applications and only overwork that helped me to stop draining the battery is to download the Task manager and kill all nookdev processes before putting the nook to the sleep. Seriously - the problem is caused by some of the nookdevs software....

It appears the problem is the reader software used when you sleep your Nook. The B&N default reader will constantly phone home (particularly bad if you are using a 3G Nook). The solution is to use one of the alternative readers. Personally, with the default reader I'll lose power overnight while in sleep mode. But with APDFViewer I can leave it on for a week and still have plenty of power left. This is something I tested pretty thoroughly, although it may not be the issue for everyone. Other software, such as Trook, can be the source of some issues.


Error with the XML file for ru.mynook.launcher, should be the following:


   <title>MyNook.Ru Launcher</title>
   <link type="application/vnd.android.package-archive"
         href="http://nook-rus.googlecode.com/svn/trunk/repository/ru.mynook.launcher.apk" />
   <version>1.5.6</version>

-LVNeptune/mastag22

I updated it now in nookMarket. Thanks ---Hari 17:03, 15 August 2010 (PDT)

I installed 1.5.6 through NookMarket and clicked Open afterwards and it locked up my Nook. It's just a solid back screen on both screens. Rebooting and battery pull didn't work. This totally screwed up my Nook. Any help?? --koolkat67 12:13, 16 August 2010 (PDT)

I finally got through by doing the second portion of SoftRooting with the External SD card...yeah that was scary. --koolkat67 12:36, 16 August 2010 (PDT)

ok now I tried to install again with NookMarket and clicked DONE at the end and have the same results. Definitely something wrong with this install. --koolkat67 12:45, 16 August 2010 (PDT)

Same problem here. Updated MyNook.Ru Launcher 1.5.6 (gave ***Update Available*** in nookMarket 0.0.2) from 1.5.1 (I think), and after install - CRASH! Also had to reSoftRoot from SD. --Cuz 20:50, 16 August 2010 (PDT)


I just successfully softrooted my nook...NICE JOB all!!!

I'm a bit confused about Pandora as It hangs on a screen that asks If I have an account.

I'm connected to my WiFi and the locker is on.

I'm thinking that VNC may be the problem but when I look at the app page it says "androidvncserver is already included in Softrooted images 1.2 and higher"

Can someone help me??? 08/14/10

I recently softrooted and think nookdev has done a great job as well. AND I have the same problem with Pandora. Also, I found that CNV Viewer4 can't get data from my nook. It recognizes the address NOOK_IP:5901, but says there is no data. I got the port 5901 when I used adb to start androidvncserver. I'm not sure how much I would use Pandora on my nook, but I would like VNC access. Sept 21, 2010



Does anyone know how to update to the new version of MyNook.ru Launcher? kevin 8/12/2010

I did it by going into Task Manager, shutting down Nook.ru Launcher and while still in Task MAnager using ADB to uninstall and install Nook.ru Launcher.--koolkat67 11:59, 16 August 2010 (PDT)



Hi again, I didn't get around to to that beer, I started fiddeling about with scripting. We use wpa and peap so I have to do some magic with the wpa_supplicant.conf file to get connected. I followed the instructions in tips and trick and it works fine. However, I am not all that happy about leaving my password in clear text on the nook. So I figured I could make a script that shut down wpa_supplicant, asked for my password, made a temporary configfile, started wpa_supplicant whith the new config and then deleted the config. It soundet so easy until I tried and ran into all sorts of problems as I am not very good at scripting (I used perl as I at least have looked at it before), nor am I that fluent in android. I guess there is a network stop/startup script somewere on the nook that would come in handy. Could anybody point me in the right direction ? Hebo, 12.08.2010.


Hi, I just rooted my nook, great work. It really adds value to the reader. However when I copy over a large (about 140mb) pdf named ABK.pdf it turns up as A9R3229.tmp in "My Library" (nookdev). It shows up correct in the filemanager, and it can be read as a normal pdf with apdfViewer. Other (and smaler) pdfs show up with correct names. Any ideas on how to make it show the right name ?

I would also suggest a slidebar on the apdfViewer to scroll down the pages, similar to "go to > pages" in the ebook reader. Clicking down to page 386 in a 641 page pdf is less than user friendly :-)

Being abel to turn off the light on the touchscreen imediatly and also being able to prevent it from turning off could also be useful for some of the apps, espesially the Viewers and games. I am not a fast chess player :-).

Filtering out directories and/or file suffixes in the "My library" scan could also be useful. I dont want my html books to show up in "My library" as I read them with the webbrowser. Hebo, Norway. 11/08/2010.

I think I remember having problems with PDF names as well. I now end up converting them to epub using Calibre and it goes away. Probably not the best solution but it works. --koolkat67 12:42, 11 August 2010 (PDT)

See if the title property is set for the pdf file. You can check this in Acrobat reader - File-Properties-Description tab.

For skipping folders in nookdevs library, create a file .skip in the folder. --Hari 14:40, 11 August 2010 (PDT)

Yepp, that worked. Two problems solved in one day, thanks. I think I'll celebrate with a beer :-) Converting this pdf was not really an option, I could not tweak Calibre to produce a usefull epub. Hebo, 12.08.2010.


Hi, I just cannot get ADB over USB connected on my Win7 x86. The driver is all good but the command line simply return "device not found" error. Is is possible to change back to ADB over WiFi ? By Erikace, Aug/10/2010

If you've installed the driver correctly then try
adb kill-server
adb start-server
then continue adb commands
also make sure adb is started in Wifi Locker on the Nook --koolkat67 12:40, 11 August 2010 (PDT)

Hi Kookkat67,

I did kill the server and restarted, and I kept the adb active. But I still didn't get any connection. Actually I've already deleted the wifi locker because it's useless. When I usb adb over usb on the laptop in my office(Win XP x86), it works perfectly, just like plug and play. Any idea about what may wrong with my win 7? ---Erikace, 1:41, 13 August 2010 (PDT)

Eikace...email me where you see an error or issues. koolkat67@hotmail.com It's not easy to keep up with forums here, I JUST noticed you replied. I've been able to connect to Windows XP and Windows 7 so I'm curious where you're getting stuck.--koolkat67 14:27, 23 August 2010 (PDT)


Hi, is possible to run the app StudyDroid in a nook device? I think would be great use a flashcard app in nook. Flashcards are realy useful for how want to learn something. http://www.studydroid.com/index.php Pedro - Brasil. 10/08/2010


I like what I am seeing here guys, good stuff! May I suggest trying to get the Kindle Android eReader app working on this device? That would certainly make my decision as to which device to purchase a no-brainer! Bajangerry - 5th Aug 2010

Hey Bajangerry. At this point I would even like "Nook for Android" app working on nook! (seriously). it even has reading in landscape mode. --Spec 08:50, 5 August 2010 (PDT)

Someone has to look into upgrading nook to a later version of android first. We can at least try installing these apps then. --Hari 16:09, 5 August 2010 (PDT)

Hari, looking at news like this one would have to ask themselves first What's the point spending all that time... --Spec 21:00, 8 August 2010 (PDT)
Couldnt help myself link. Everyone who feels the same please join me by adding your comments. --Spec 07:26, 9 August 2010 (PDT)
Spec, my problem with Tablets in general is that I want a eInk screen as it is much better for reading. --Bajangerry 13:21, 10 August 2010 (EST)


I assume it is a case of the hardware not being capable of handling the new version of Android then? I am in Barbados and don't even have one of these devices as yet... one day! Bajangerry 7 August 2010


It's possible to send SMS with the nook?

(of course using my own sim) -- Dez


Can it be that the new 2.4.1 Softroot and the tun.ko module supplied in the OpenVPN section is not compatible?

insmod results in an error

#adb shell insmod /system/lib/modules/tun.ko
insmod: init_module '/system/lib/modules/tun.ko' failed (Exec format error)


Investigating the error:

# dmesg | grep tun
dmesg | grep tun
<6>IPv4 over IPv4 tunneling driver
<6>GRE over IPv4 tunneling driver
<3>tun: version magic '2.6.27 mod_unload ARMv6 ' should be '2.6.27-svn18303 mod_unload ARMv6 '

Should the TUN module be recompiled against the new kernel version - or? Any hints to what could be done? The IRC channel seemed quiet in my time zone :-)

/W



How do you change back to ADB over Wifi. the new Softroot 2.4.1 has it default to ADB over USB (which I can't seem to get to work) --koolkat67 11:56, 29 July 2010 (PDT)

ok nevermind, solving my own problem again...lol. If anyone has the same issue, i can explain how to do it now. --koolkat67 14:22, 29 July 2010 (PDT)


Was anyone able to set the Mynook.ru Launcher as default? --koolkat67 16:36, 28 July 2010 (PDT)

Nevermind, I guess you have to uninstall the previous Launcher --koolkat67 16:54, 28 July 2010 (PDT)


I couldnt find any documentation about the function of the "wifi" app that appears on the nookLauncher bar. The B&N version is of course used to manage wifi from the home screen, but when I try the one on the nookLauncher it simply does nothing (configuring wifi still works fine in settings). Am I missing something or is this app just broken in the nookLauncher? Thanks for anyone who chimes in. --nall256 12:11, 28 July 2010 (PDT)


I've run into a huge problem with my nook (strangely, no-one else seems to have come across it). Whenever I start it up, it goes through loading, shows the upper information panel (battery, time, and on the left, it doesn't seem to be able to refresh properly either- USB drive mode is still there 5 minutes after ejecting it from the computer and unplugging) and a message: 'Sorry! The application Home (process com.bravo.home) has stopped unexpectedly. Please try again.' with a 'force close' dialogue on the lower screen.

I've tried shutting down and restarting, rebooting (through the 'turn it off, take off the false back, take out the battery and put it back in again' method), force resetting (the home button and the power button) and finally using the fallback option (turn it off, hold down the power button for 12 seconds, 6 times to produce a black lower screen with a blue progress bar)...nothing has worked :(.

Initially, I had all but perfected the setup (the ru. nook menu and icon restyles, twook, busybox, 3G- though not through the web browser- and waiting for the server certificate for my school's EAP-PEAP network), followed the last instruction (with 'update' in front of it) in the 'Using International SIM card' section and noticed that now 3G did not work AT ALL. Putting that aside, my nook is now utterly useless...

Has anyone encountered this, or have any idea what kind of problem this could be (i.e. the dreaded hardware fault :|)? Also, I have an Optus SIM card inserted, is it best to take this out on (what the nook thinks is) first start?

Oops, forgot the signature: --RNA-Wrangler 02:51, 25 July 2010 (PDT)

When you say your e-ink isn't refreshing do you mean that it is stuck on one image or do you mean that it can't properly go blank and then load a new screen? My nook encountered the latter and had to be replaced (could only display dark gray and black and each new 'page' loaded on top of the previous). I didn't encounter any software issues with mine though... --Specialcircumstance 03:23, 25 July 2010 (PDT)
Right, sorry about not clarifying that. Yes, it does that only when I connect it via USB to my computer, and it seems to only be a matter of it not recognising that its out of USB mode. Time and battery monitor works perfectly. I just did another reformat and it seems to be working tenuously. I'll go stepwise slowly (hopefully not encountering the game-ending 'home has stopped working' message).--RNA-Wrangler 03:32, 25 July 2010 (PDT)
Ahah! Pinpointed the exact circumstances of the problem. I'd attempted to recover my APN list (after modifying it, getting 3G working in everything bar the browser and then using the update beneath that, which wipes all APNs) by donwgrading to 1.0.0, which worked, then I shut it down to install the rooted update, neglected to hold the right 'back page' button and the 'home is not working' issue arose. Speaking of which, provided my attempts don't make the nook CPU fry itself, does anyone know exactly how to get the nook browser to work with 3G (I can't quite follow 'Update: nookBrowser checks for WIFI in 3 places in nookBrowser.java file. Just search for WIFI and comment out the line & uncomment the line below that and rebuild')?
--RNA-Wrangler 04:00, 25 July 2010 (PDT)

What I want is a Nook app to capture (bulk preferred) ebooks when you log in at a B&N store that persist after you log-out or leave the store. Offering $50 USD bounty in Liberty Reserve, c-gold or Pecunix digital currencies or other means by prior arrangement.

--Castell.faber


Can someone fix up the nookLauncher page since 0.0.8 is out?


I'm looking for help on making an easier way of navigating on apps that don't fit. For example, Pandora and Google Voice. With those you need to use VNC to do anything. I was thinking a way to use the page turn arrows, the right side is up and down, the left side is right and left. A combination of two of them would be select, a different combination would be back. OR A combination of the buttons would pop up an arrow pad on the touch screen that would be over any of the other apps that would allow you to navigate. In order to the the touch arrow pad, all apps would have to be automatically resized to the top screen only.. Unless someone knows a better way.

Anyone have a suggestion? --Houseonfire 12:35am, 15 July 2010 (PDT)


As of a few resets ago, my rooted Nook Wi-Fi shows a "vibrate mode on" icon (I found an image of default Android icons and concluded this is it) on the status bar (to the left of the Wi-Fi and airplane mode icons). A regular 5s and a 20s "hard" reset didn't change anything. I also found a "vibrate_on" setting in the Android settings database (table "system", ID 8) which was set to 4 and tried a few different values -- to no avail. Moreover, I tried disabling vibration via the corresponding two AudioManager properties, with no effect either. Any idea where this erroneous setting my be stored so I can reset it, and how it may have been set? --Curio 13:25, 15 July 2010 (PDT)

--- The nook does not vibrate... So... I guess you could do a full reset to default settings and reroot it again. It's easy enough to do.

Of course it does not vibrate. ;-) And I'm aware that re-rooting will likely solve the issue. Yet as it's happened once, it may happen again, and as re-rooting will lose all manner of settings (or doesn't it?), I'd like to find out how this has come about. Prior to the issue, I tried out nookBrowser for the first time -- but this is not to say there's clear reason to blame it on that. --Curio 23:30, 15 July 2010 (PDT)
Some more experimentation led me to the following resolution (just posting it for the protocol, or in case someone else experiences the same issues): In the Android settings database, "mode_ringer" was set to 1 but defaults to 2. Changing this (plus a reset) made the icon disappear. I still don't know what caused this, though; my bets are on the browser.

Anyone in the know how to add the B&N games browser to nookLauncher? On the device, there appear to be only APKs for the actual games, but none for the game selection screen provided by the original B&N home. --Curio 09:37, 14 July 2010 (PDT)

-- This doesn't work right now. I'm planning to add this. But might be a while. You can keep track of this using http://code.google.com/p/nookdevs/issues/detail?id=94

If you select the star on the top lef corner in the issue detail page, you will get alerted when it gets updated. --Hari 08:36, 15 July 2010 (PDT)

Thanks, I created that issue myself. ;-) I guess this section can thus be removed from the wiki forums. --Curio 13:25, 15 July 2010 (PDT)

how do you uninstall Twook? I'm having serious battery drain problems suddenly and the latest changes I've made were Twook and softroot 1.4. and Yes, I'm on Airplane mode so its not that. --koolkat67 14:09, 28 June 2010 (PDT)

I am having this same problem. Finished reading last night while in airplane mode, battery was at 82%, nook went to sleep. When I turned it on this morning it was at 3%. I haven't even installed Twook, but I softrooted 2 days ago. Solutions anyone?

I currently suspect that my softrooted Nook Wi-Fi doesn't turn off Wi-Fi of its own accord, i.e., when reading and when in sleep mode. I could verify the latter by my router's listing of connected devices: the Nook stays there all the time. Could you verify if this may also be the cause of your battery drain issues? On the other hand, if this issue is specific to the v1.4 softroot, I wonder why similar reports aren't flooding this forum and others? --Curio

Update: Trook appears to leave Wi-Fi turned on indefinitely once one has accessed the network using it. Explicitly shutting down Trook (via Trook's settings, Stop) restores the Nook's original behavior with respect to Wi-Fi auto-turn-off. I've also noticed that -- at least with the v1.4 softroot on a Nook Wi-Fi -- there is no file "TrookPreferences.xml" unless one creates it (I don't know whether or not the file should be there by default). I did create the file myself with a timeout of 60s and a hold-on period of 180s, but this didn't change the observed behavior at all. --Curio 00:10, 8 July 2010 (PDT)

Update: I followed Curio's suggestions and even went further and removed Trook and Wifi Locker using the Laucher settings and I turned wireless on and then turned on airplane mode and hard rebooted it and am still seeing very fast battery drain. I wonder if the difference might be wireless only vs. wireless+3g or maybe it's due to me removing /system/app/FirmwareUpdateService.apk. Sadly, I think I have to revert back; even though the softroot is awesome, I travel light and am extraordinarily lazy and don't want to bring my charger on short trips. If anyone has any other suggestions, I'll greatly appreciate them. --cleanest 15:43, 10 July 2010 (MST)

I would check whether ADB is still running in the background. I had horrible battery drain issues w/ 1.4.0 softroot if ADB was still 'running' per WiFi locker. When I stop ADB and 'unlock' WiFi Locker, as well as put the Nook in Airplane mode, I get much better battery life. I probably charged the Nook three days ago, with reading average 2 hours/day since then, and it's around 60% still (also have shortest timeouts for LCD and screensaver - 30 seconds and 5 minutes, as I recall). --Dan

Curio, I tried everything to be in Airplane mode and turn off Wifi; it appeared to be off in the Settings and Wiki Locker. Removing Trook did nothing to help the battery drain. Reverting back to Softroot 1.3 made a world of difference. My battery is now in full form. I'm also curious why there haven't been other responses. I even tried going back to 1.0 and then to 1.4 but the battery still drained extremely fast. --koolkat67 14:23, 13 July 2010 (PDT)

Koolkat, I have no idea what made the difference but my battery issue seems to have cleared up. 12 hours in sleep mode only drained it 3%. I turned on airport mode, I turned off trook, I turned off wifi locker, and it was still draining super fast. I used launcher settings to remove trook, and web, and wifi locker and I felt like it was still draining super fast. But then later it crashed and I had to reboot it and ever since it's come back up, the battery has been in full form. weird. I'm also surprised there's not more ppl noticing this. I guess I have no idea though the size of this community. --cleanest 21:00 13 July 2010 (MST)

Seeing the same problem on my recently-softrooted wifi-only nook. It was draining battery pretty quickly, so I switched to airplane mode yesterday afternoon...batter was around 50%. Didn't touch it, and this morning the battery was dead. I haven't gotten around to connecting adb to it, so this is the plain-jane softroot image. --rascalking 08:47, 14 July 2010 (EDT)

Cleanest - that happened to be me too where the battery started working which was scary cuz I didnt know why and of course mysteriously the problem came back again when I least expected it. Let us know how it turns out for you. --koolkat67 09:08, 14 July 2010 (PDT)

The power/battery drain issue is a general 1.4 problem that all users are experiencing. I just found the nookdev site to root my nook in hopes that you guys had found a solution before B&N. For more information check out the lay person's nook forum at http://bookclubs.barnesandnoble.com/t5/NOOK-Q-A-and-Support/Nook-power-issues-since-1-4/m-p/563731#M16036 --W-Tramontana 04:49, 19 July 2010 (PDT)

ok here is the latest. I can make my battery drain everytime BY Connecting via ADB and NOT Stopping ADB in the Wifi Locker. I have even put it on Airplane mode and leave the Wifi location I connected in it'll drain everytime. If the writers to softroot agree maybe there can be a user input to turn off ADB after a certain amount of time. For now just make sure you turn it off after using it.--koolkat67 10:12, 22 July 2010 (PDT)

I'm also have the problem of quick battery drain. I tried to do some test and found the following: battery life seems to be normal after a reboot; it quickly drains once wifi is turned on; it's strange that from time to time I see 3G marks appears and disappears but I'm not in US and didn't change SIM (anyway to stop 3G only?); I did try turning Trook off from menu, stop ADB from wifiLocker, put into airplane mode... none of these works to stop the battery drain. My nook is soft rooted with 2.4.1 and app. are updated to the latest. Could anyone point me some direction to check? Thank you very much. YChao 05:32, 1 August 2010 (PDT)



Even if it is only cosmetic: Would it be possible to update the nookLauncher with the more recent B&N launcher's looks (rounded, shadowed icons)? I guess the current looks are reminiscent of the original B&N launcher because nookLauncher was based on that. Have "holes" been plugged in more recent versions, making it impossible to use them with the nookLauncher, or has it merely not been considered yet due to more pressing issues? --Curio

Most users (me too) just like this original and unique button design. B&N got thousands of negative posts on the B&N forums after releasing v1.2, cause they changed the button design to this boring and uninspired "new" look, which is used by nearly every mobile phone. If you don't like the buttons, you are free to change them on your own. Dominik 05:24, 7 July 2010 (PDT)


Can somebody please make a DJVU reader. Would be very greatful. Thanks --Ldnook 07:37, 5 July 2010 (PDT)



I successfully soft-rooted my B&N WiFi. Followed the same process as the 3G. Went off without a hitch, and I was able to remap the keys and install Trook. Something that bothers me though: if you know the IP address of a Nook, anyone can be root and change settings! Is there a way to disable adb access on the device? If I understand it right, even killing the adb server is not enough, because when the client tries to connect, the server gets restarted. This is a huge security hole, no? -- Lak

--- Hi, I accidentally deleted my /system/app/FirmwareUpdateService.apk and really need it I was wondering if anybody could send me a copy of the file. Please send it to jteplitz602@gmail.com I will really owe anybody that does. --- Hello folks! I recently bought a nook and tried to use it in Austria with a A1 Sim-Card. I changed the settings in the SQL-Database according to the settings used in my linux box: APN:a1.net USER: ppp@a1plus.at PASS: ppp . The problem is now, that nook apparently can't make a connection. The dial-in number for A1 should be *99#, I also tried to change that in /system/etc/ppp/chat-isp

Which script is called when nook tries to make a 3G connection? Can I view a log output of pppd to debug the dial-in? --Reini1305 22:47, 29 June 2010 (PDT)


hi, any plans of adding kindle app to nook? since amazon has released kindle app for android, any plans of adding it to applications list? --Mindseye73 18:15, 28 June 2010 (PDT)


I am trying to get the emulator working by following the instructions here: http://nookdevs.com/Emulator. I am stuck on step #10. I do not see a file called ServerThread.smali in the directory. All I see is 3 files named ResetTimeout*. I think I did it right. Can someone help me get past this? TIA.

Hi, Try checking in folder "out\com\android\server", if it is not there, then you must have missed some steps.--Mindseye73 18:16, 28 June 2010 (PDT)


I just installed rooted 1.4.0 from 1.0.0 and I'm running into a weird issue where if I try to change the screensaver, it crashes back to the main menu. Everything else works normally albeit with only the fallback golden gate bridge ss. Adding additional screensavers doesn't change anything. Any ideas? --Specialcircumstance 02:28, 25 June 2010 (PDT)

Okay, fixed. Tried and true method of reverting back to 1.0 and reinstalling. I suspect I initialized the upgrade to 1.4 before 1.0 had fully sorted itself out. I was actually getting the warning about fully charging the nook before first use when 1.4 booted. --Specialcircumstance 03:03, 25 June 2010 (PDT)

I had the launcher icon problems with 1.3 -> 1.4. I uninstalled launcher and reinstalled it, and everything was all better. --6502programmer 11:42, 24 June 2010 (PDT)


Has anyone tried to softroot one of the new Wifi-only Nooks? Do we know if the firmware is compatible? Dmac 06:37, 28 June 2010 (PDT)

Great question, I just got mine an hour and a half ago (unfortunately, it's at home) and was wondering the same thing. I'll probably await confirmation that it's safe before trying it myself though... --Iamboring 10:09, 24 June 2010 (PDT)
Wi-Fi only nooks can be rooted with the same process as 3G nooks. Just finished with the assistance of Ncommander and poutine. --Muchadoaboutnothing 17:39, 24 June 2010 (PDT)
Excellent news - looking forward to spending some hard-earned on one when I'm stateside in a few weeks. Thanks for the effort! :o) Dmac 06:37, 28 June 2010 (PDT)

I couldn't change those two icons no matter what I did, but downgrading to 1.0.0.0 and softrooting 1.4 from there worked flawlessly...


right, it was the Red/Maroon colored Use As Default Launcher that took me to the Launcher Settings. It took me a few tries, I had to remove a couple of buttons at a time, then add them back in. Eventually its all squared away now. I'm sure, as you said, they'll have a new version soon. --koolkat67 16:33, 22 June 2010 (PDT)


@Kat Unfortunately, I have no way to get to the launcher settings as far as I can tell. The Launcher Settings icon that is blue simply takes me to my current position in the book I'm reading, and the Launcher Settings that is white does nothing at all. The few icons that actually have something written on them do not do what they say (except trook), but most are simply blank or have an unintelligible symbol >shrug< EDIT -- the brown Use As Default Launcher icon takes me to the launcher settings. Unfortunately I cannot remove that icon or the +, so "use as default launcher" is the only thing I can use for "Launcher settings" and "+" is the only option for "B&N Home." I may try using it, but will still probably go back to 1.3 as it was at least accurate as to icon labels.


I figured it out...if you remove all the bad icons with Launcher Settings and add them back they are good again.--koolkat67 15:34, 22 June 2010 (PDT)


@Koolkat67 I had the same problem. I redownloaded from the direct link and the hash doesn't match. I downloaded from MultiUpload and the hash matches the direct download but not the hash listed in the directions. I may try downgrading to 1.0.0.0 and softrooting to 1.4 to see if that works, but I'll probably just end up reloading 1.3 until 1.4 gets fixed...


Not sure if this is the place to post it but I just installed 1.4 and all the icons are screwed up. I installed 1.2 and 1.3 along the way successfully.--koolkat67 12:37, 22 June 2010 (PDT)


Version 1.4 has been released bty BN. My rooted nook downloaded and installed this automatically, so pay attention if you are connected via wifi.

Thanks for the heads up. My nook is not going online until 1.4 softroot --Spec 20:35, 21 June 2010 (PDT)

Any idea if there is any possibility of running the Wikireader on the Nook, by using the Wikireader update? Would be amazing, imagine all wikipedia articles on your nook.



I've had success following the instructions to emulate the nook with the Android SDK and noted with interest the statement that the same can be done with the softRoot. My question is - how do you extract the information in the softRoot file? I've tried applying the same strategy for processing the 1.0.0 image file but can't extract anything from it. Thanks! joemw

__________

For all of you who, like me, are over-challenged with how to fill the 2GB on their nooks, Shelfari[1] is the 'Facebook of books'. You can enter the books you enjoy and it will show you other users with books similar to your preferences for you to browse. hope this helps :D

I'm sure it would make a great nook app as well ;)


Nook Rotating Display for PDFs

Is there any way to allow the Nook to rotate the screen display like the Kindle does? It would be amazing for reading PDFs. Allowing it to Zoom and navigate like the Nook browser with the touchscreen would be an added plus. How hard would it be to create an app for that or build it in? Without this, reading PDFs with images/diagrams is miserable. Please helppppp!!!!



I have looked all over the nook options but can not find a 'go to page'. I thought that this would be one of the fundamental options in the nook. Does anyone know how i can skip to the middle of a book? -- 05/11/2010 Sorry to tell that there is no such function in Nook. This is the most let-down-missing function for all Nook users. (bthoven)



########## Idea for running 3rd party apps on the nook - write an android app that emulates a mouse cursor on the eink display which is controlled by a finger on the touch display. Elegant fix to the problem of the e-ink not being touchscreen. Use the touchscreen as a touchpad.######### Here it seams the way to go... http://forum.cyanogenmod.com/topic/18548-cm7-mouse-pointer/page__st__80 Mija 04:09, 26 June 2011 (PDT)


Does anyone would please edit the "International SIM Card"-Section and explain the commands step by step , like a guide for dummies, or better make a video! Thank You!!


I don't know if I'm the only one who has had this happened to, but I figured I'd note it just in case anyone else runs into this problem. I installed the 1.3.0 rooted update yesterday; with version 1.2.0 I followed the instructions in the FAQ for disabling auto-updates, but neglected to do so *again* after installing rooted 1.3.0. Left my nook in 'sleep' mode, came back to it and found out that it was in the process of downgrading itself to version 1.0.0... I watched as it continued to update itself back to 1.1 then 1.2 then 1.3 official update.  :(

And since I had downloaded a lot of stuff to the internal sdcard drive, lost all of it.

A word to the wise; if you haven't already disabled auto-updates with the 1.3 rooted version, do so.

---

Installed the rooted 1.3.0 update. Love it (so fast!!!) Thanks guys. But my Chinese books (in epub format with UTC-8 coding) are no longer listed in Chinese characters in "my library". I just see a bunch of scrambled letters in the title and author fields. I can still open them and the Chinese text shows up fine in the reader.

Everything was working perfect in 1.2.0. I used Calibre to convert and transfer the books...

Any ideas?

A bit unrelated comment, but I'm also on 1.3.0 as of few hours ago and I'm not sure if I see any difference in speed of turning pages. The speed of opening ebooks seems to be the same. Page turns maybe a bit quicker but not like 100% quicker, more like 10% quicker. It seems like b&n set expectations a bit too high for me. -- Spec 21:50, 23 April 2010 (PDT)

Just a heads up everybody, the 1.3.0 update is out, can't wait to hear if it is safe or not :D, but for the meantime, no one should update until we get word that it is safe.

____

Hmmm, there are system sounds (like page_turn.mp3, power_down.mp3) but my nook doesn't use them. Does yours?


I read somewhere about re-mapping the buttons on the nook. I guess the next question would be; is it possible to re-map the nook buttons to function like the hard buttons android expects? Like menu, back, home, etc. Might help with running non-nook apps.


my solution to read Chinese or other languages is in the following way 1 save your epub file or pdf file to basic html file with correct encoding 2 upload to your drop box or any website 3 use nookbrower to read them my question is can nook broswer read local file like regular broswer on a desktop? I didn't try it now, for example file:///sth like that, can anybody give me an example?

thank you

User MLALAHOI asks: My Nook hasn't shipped yet, just inquiring to those with device in hand, can you confirm whether or not it can display Chinese characters? Thanks!! - February 2, 2010

Nook does not directly support Chinese characters, but will display PDFs containing them. - Boogedyboo, February 2, 2010

I tried out a Chinese epub. On the 'My Documents' page it displayed Chinese characters in the title, but couldn't display them when I opened the actual book. My guess would be that if you replaced one of the fonts with one that better supported Chinese it might work. Baka no Kami 2/2/10


Can someone tell me whether nookbrowser works on 3g, or just wifi? This is the deciding factor for whether or not I purchase a nook. Thanks!

nookBrowser currently works only on WiFi and I do not believe there are any plans to extend it to 3G. Exploiting the free 3G service would probably get BN and AT&T rather upset, and the nookDevs folks are trying to avoid that. --Zyrjello 00:17, 6 February 2010 (PST)
works on 3G if you use your own SIM-card, like posted above, no free 3G on B&N dime. Stangri 20:28, 5 March 2010 (PST)

As suggested in the "font changing" section, I replaced all 6 amasis system fonts with STHeiti fonts (a san serif font) with a big unicode table including Chinese glyphs. But the pages in the epub still show something look like amasis fonts (serif font) with ???? in places of the Chinese characters. Why the new fonts are not used by the android OS? Thanks in advance.

The application which reads (well, displays) epubs uses its own fonts. You can either embed the fonts into epub or reference the external fonts with the style sheet. There was a post about it on mobileread. Stangri 20:29, 5 March 2010 (PST)

Has anybody found a way to connect a mouse to Nook?AaronMFeld 9:59, 19 March 2010 (EST)


Is it possible to create the missing Comic Viewer App? To be able to read .CBZ/CBR. Or is there a way to port Android Apps to nook? Thankswillylatorre 3:00, 22 March 2010 (EST)

You can easily turn cbz/cbr comics into ePubs with Calibre. Just import the cbz (make sure the pages are properly sorted) and convert to ePub. The only problem is that the bottom of some pages is cut off by the progress bar. This can probably be fixed with some configuration magic in Calibre though. --Mastapsi 11:27, 22 March 2010 (PDT)

I'm curious about how to read scientific papers. While for some the layout is fine, for others is important to respect a (usually) two-column layout. I tried to use the ook in landscape mode (rotating the pdf file) but didn't work. Any suggestions?agraves 12:25, 13 April 2010 (EST)


I softrooted my nook yesterday, and everything worked great... almost. The browser is something that B&N should've done themselves. My problem is that the clock hasn't reset yet, and it's been nearly 24 hours. I've turned airplane mode on and off, wifi on and off, and had every app sync with B&N. Still, I'm stuck in UTC time. I'm making progress with the SDK installation, but I'm definitely no programmer. Any ideas what I'm missing?



Does anyone know what font is used on the nook app icons?--Kyeld 14:11, 15 April 2010 (PDT)


Is it plausible to replace the epub reader and maybe the pdf reader as well? I find the UI very slow and frustrating. Perhaps its a mistake but I'm trying to read technical specifications like the HTML5 spec. I've put it into epub format and if I just want to read it, its ok but if I want to follow a link, it is hard to navigate to the link I want to follow. There also needs to be a history of followed links so that a user can go back to the place they came from. B&N doesn't seem to care at all about these issues.--Thank you, 07:33, 19 April 2010 (PDT)


Nook forums are full with user complaints regarding reader battery life, and it doesn't look as B&N cares too much ("turn airplane mode on, don't read more than 1 hour a day - you have your promised 10 days!"). I've disabled firmware update service, and I was wondering if more services from /system/app can be removed to make battery life better? --Silencer 14:34, 29 April 2010 (PDT) Bold text Bold text


Somewhat related to the Nook is the B&N Desktop eBook reader. It uses some kind of sql-lite DB file located in "C:\Documents and Settings\<windows user name>\Application Data\Barnes & Noble\BNDesktopReader\ClientAPI.db" . Contained in this file are some urls and the username/password to the users BN Account in plain text. I read this file with notepad. (security breach here?). I'm wondering if there's anything of value in this file that would lead to a solution in getting your own custom content published to your personal Nook daily?.--User:Red5 04:15, 06 August 2010 (CDT)



nook softrooted with 2.4.0 I've installed adb over usb. I've installed the windows driver. But I can not connect: error:device offline. I've checked adb is on on wifilocker. --Hlastras 08:31, 20 August 2010 (PDT)

This has been asked before and answered, but the error is just a message that is displayed, you can adb shell, adb push, etc, it does not actually affect adb's operation.
I don't understand... What I get is this:

C:\Program Files\android-sdk-windows\tools>adb shell

error: device offline

C:\Program Files\android-sdk-windows\tools>

--Hlastras 13:49, 20 August 2010 (PDT)

Solved: I re-softrooted with 2.4.1--Hlastras 08:35, 22 August 2010 (PDT)

I have followed the instructions to setting up a wifi hotspot using EAP-PEAP authenticity, but after I pushed the .pem certificate with my modified wpa_supplicant.conf into /system/etc/wifi and reboot my nook it doesn't work at all; the EAP-PEAP powered hotspots still dont appear in the list and i pulled the .conf file out before and after reboot and after comparing the files i found that wpa_supplicant.conf just returns to the old file after rebooting, what should i do to fix this? --Mgfneo

There is a wpa_supplicant.conf.template file in the same directory. The nook probably uses it to rebuild the conf. Maybe you could change it to include the eap-peap info. However, I seem to remember that the instructions worked for me. Now I use a perlscript to add and remove the info so I dont leave my password on the nook. I'll se if I can publish the script here. Hebo, 28.08.2010.


Dropbox on Nook

Dropbox is capable of being set up and running via command line. Is there any way to get it working on nook? I'm not looking for a GUI or anything, just something that can run in the background so I can keep what's on my nook backed up elsewhere. Dr. Skullthumper 15:08, 6 October 2010 (PDT)

Dropbox is already installed on nook both vanilla and softrooted. For list of commands on softrooted nook check out This page on the bottom of it. --Spec 17:35, 6 October 2010 (PDT)
I have softroot 2.4.1 and can't find a way to use Dropbox. I also don't see a command related to the Dropbox process on the page you linked. Sorry - I'm not much good with the command line and I'm a bit confused =/ Dr. Skullthumper 06:04, 7 October 2010 (PDT)

Why Register?

I am looking at rooting my new hardware nook but haven't registered it with B&N. Since I am outside the U.S. and can't buy B&N e-books online, is there any reason I should bother to register?


Refurb nooks from BN avaliable!!! It looks like BN is selling refurb nooks on ebay: BN nook store on ebay The 3G nook is only 99 bucks.


I believe that we should wait for the folks that do the coding to have some idea of what to do. In the mean time definately do not update. (This is a new version of android as I understand it), and we may enter a situation requiring different utilities on the rooted nook).


Just for the heck of it I turned updating back on for my rooted 1.4.2 Nook and let it update to 1.5. The update worked and my nook was still rooted with all the apps I installed running fine so far. The only thing I need to fix is that whenever I exit an app it pops up a question to use either Home or the Launcher. Unfortunately there are no controls to click the checkbox that allows you to set the default. I am assuming there is a configuration bit I can flip somewhere but I have not yet delved much into the Android backend to know or find out where it sits. --eridium 12:43, 23 November 2010 (EST)


I just started playing around with ADB over USB. I tried following the instructions provided on the wiki for Windows installation but there are some differences:

1. There is no C:\androidsdk\android-sdk-windows\SDK Setup.exe, there is only C:\androidsdk\android-sdk-windows\SDK Manager.exe.

2. I installed SDK Platform Android 1.5, API3, revision 4

3. I got root access and there seems to be an install command, but other commands such as uninstall, push, and pull don't seem to work.

Did I do something wrong or did something change and what can I do to fix this? TIA. ---

Running ANY Android app on Nook Classic

http://code.google.com/p/virtual-touchpad We need to develop that app to be able to run any Android app for 1.5 beeing able to click anywhere in the eInk screen on Nook Classic.--Mija 01:56, 5 July 2011 (PDT)

Nook 1.5

Nook firmware 1.5 just came out: http://www.nook.com/support --Spec

The Bookshelves are neat in the new release, however they don't seem to allow spaces in their naming convention. The page turns are much much quicker. And of course there is a newer version of android to explore once we figure out how to deal with it here! I am hoping for a fast upgrade to the new OS!

newer version of android? --Spec 18:07, 22 November 2010 (PST)
Hi, Is there a update to the tun.ko module for open vpn it seems the latest one for 1.4 fails when I insmod
Is it still possible to roll-back to 1.0 after upgrading to 1.5? I'm quite eager to try out the new features but would like to keep the possibility of rooting. YChao 06:26, 23 November 2010 (PST)
I was able to roll-back to 1.0.0 using the usual method after the 1.5 upgrade without any problems. --Buzz 09:11, 23 November 2010 (PST)
Now I have successfully re-rooted after the 1.5 update using the standard documented procedure for SoftRoot 2.4.1. --Buzz 12:00, 23 November 2010 (PST)

This is the first update to come out since I rooted my nook. What's the procedure here? Don't update?

What do you think of this -> Nook 1.5 with Root and ADB (http://andblogs.net/2010/11/nook-1-5-with-root-and-adb/)? is it true?

So far I have not been successful in applying this update, but trying hasn't harmed anything. --Buzz 12:00, 23 November 2010 (PST)

Someone just posted nook 1.5 softroot 2.5.0. No other details. I advise to wait for official news on this site (if it ever comes). Personally I'll run a diff to see what's the difference between official and this build first. --Spec 17:18, 23 November 2010 (PST)

The above softroot modifies original 1.5 update in the following way: 1. installs apdfViewer.apk , nookBrowser.apk, nookFileManager.apk, Nooklet-debug.apk, nookLibrary.apk, nookMarket.apk, nookNotes.apk, NookTaskManager.apk, nookWifiLocker.apk, ru.mynook.launcher.apk, 2. installs busybox and creates 127 symlinks to it, 3. fixes default launcher to be my nook.ru launcher, allows installing non market apps, and enables adb, 4. backs up and restores settings for the installed apks, 5. removes and does not install b&n's turboboot.img and u-boot.bin (didnt look what's in there but among others allowing installation of unsigned updates is in there). I'll pass because I dont like my nook.ru launcher and I think softroot should just install launcher and nookmarket - rest should be up to the user (back up of all settings is good though). --Spec 17:45, 23 November 2010 (PST) .

Can you share this firmware? The link posted here nook 1.5 softroot 2.5.0 is not working.

It works for me just tried. Are you behind firewall? note that the file is shared on port 81. --Spec 08:41, 24 November 2010 (PST)

Yeap. Firewall was blocking port 81. Got the new version of Nook 2.5.1 on here: http://www.perfinion.com:81/nookdevs/bravo_update-2.5.1.dat

Just a thought.....I've rooted a few devices, but always from tutorials. If someone with the older hardware (that had the internal microSD instead of the hardwired flash) updated to 1.5 then pulled the microSD card out, wouldn't that let you Linux gurus see what's going on with it? I may be talking nonsense, but just a thought. -- Niphoet

I think the image of 1.4.1 or 1.4.2 internal sd card (or memory) was shared already during the rooting process. it doesnt look like helped. --Spec 17:57, 24 November 2010 (PST)

Does anybody knows if this version 2.5.1 works on new hardware? (1003XX serial)? Any info on the rooting process for this harware?

I think that it is a softroot release and it only works on old hardware that can take profit of 1.0 downgrade without turning nook a brick.--Kylebofh 17:43, 27 Noviembre 2010 (CEST)

--Kolfe 02:05, 25 Novembre 2010 (PDT)

One of my friend got his Nook 1.4.1 bricked. (new hardware) Is there any way to try before sending it back to B&N for repairing?

Yes. just added this to tips and trick page. It will work as i've seen it many times. What I would like to ask you in return is to share information: 1. did the procedure work exactly as described (some places state you have to reset 7 times, some less), 2. what did the friend do to brick the nook: original firmware version and first 4-5 of the serial number. --Spec 17:15, 26 November 2010 (PST)
That's a great trick Spec, just updated to 1.5 after executing that trick. --Kylebofh 17:22, 27 Noviembre 2010 (CEST)
Thanks. I think the problem is that he flashed 1.0 firmware to his nook w/o noticing it's a new hardware. The serial # is 10031XXXXXX and the original firmware is 1.4.1. As the update also flashes the recovery partition as I understood, this trip probably won't help. I'll ask him to try it out anyways. --> confirmed not working.
He could try to force an update from B&N with this tip: forcing software update --Kylebofh 19:05, 2 December 2010 (CEST)

I installed 2.5.1 and softroot apdfviewer had a problem with, because it does not open, someone would have a solution, I'm from Brazil and I thank all the staff. I need a help, .

softroot 2.4.2alpha had an additional library with apdfviewer - libpoppler_jni.so and I was curious if it was missing in 2.5.1. Are you getting an error message at all? if no do you know how to get a logcat (perhaps it looks similar to this? BTW it looks like 2.5.1 also installs androidvncserver incorrectly too, so that wont work out of the box too. --Spec 16:13, 27 November 2010 (PST)
no error message, just does not open the file, go directly to library. ref.: problem apdfviewer
Solved pushing missing files to the nook, see updated page APDFViewer --Aidionidis, 21:00, 01 December 2010 (PST)
Thanks

. .

NEED HELP PLEASE with ADB

I have the NookColor. I just followed the directions to root this device. It seems like it all went well, but I can not install any programs ( I am trying the ones that have been confirmed to work ). Like I said, I did patch the ADB but here is what I get when I try any commands ( via Win 7 command prompt )

==================================

C:\androidsdk>cd tools C:\androidsdk\tools>adb kill-server C:\androidsdk\tools>adb devices

  • daemon not running. starting it now on port 5037 *
  • daemon started successfully *

List of devices attached

C:\androidsdk\tools>

===================================

If I try the shell I get this:

C:\androidsdk\tools>adb shell error: device not found

C:\androidsdk\tools>

===================================

Why cant it see the device ?? In device manager it shows as:

My-PC |-Android Phone

|-Android ADB Interface

Device Type: Android Phone Manufacture: Google. Inc. Location: Port_#0003.Hub_#0004

Any thought please ????


Not to ask a stupid question, but did you follow all the steps for doing ADB_Over_USB? For example, do you have the Android SDK installed? --Linals 14:09, 4 December 2010 (PST)
I think the instructions apply to nook classic not color. My best guess would that that the nook color adb drivers are not installed --Spec 16:54, 5 December 2010 (PST)
It should work for him. I just rooted my NC following those directions and I can access it. Could it be a firewall? If I where you...I would check to see if its a firewall and perhaps re-visit this NookColor_USB_ADB I would think that this is the problem. Also take notice you need to add those lines twice. I was also able to NookColor_Enable_App_install_from_on-device_installers The only downer I'm having is with trying to install ASTRO. (can anyone give me a little "how to" on installing by ADB for the NC? or perhaps where I can download apk for skype or something?) I have no idea how to do it or where to start. Sorry went off subject a bit.--Baz
the NOOOK COLOR adb over usb instructions are here: NookColor USB ADB The nook eink nook1 nook original steps will not work. Use these. Really, they work. Do not skip any steps. also, visit Portal:NookColor for more info. Rboatright 06:46, 7 December 2010 (PST)

Last.FM

Ok, it would be REALLY great if anyone can make an app to use Last.FM on the Nook (black & white). I can't use Pandora in my country. I have kind of experience in C and C# developing, but right now i dont have time to figure out how to write apps for the nook, to look at the last.fm api, and such things. Perhaps if someone have the same interest in this app we can work together somehow. --Aidionidis 11:23, 5 December 2010 (PST)

Great news!!! this last.fm app works great! http://www.csmarshal.com/ (direct link: https://www.dropbox.com/s/3lxhkpjcbhbv6tm/fm.last.android.1.6.6%28patched%29.apk) But you have to use VNC to control the input. I think that porting this to the nook would be really easy, actually we just need to map some keys and done! Someone interested in this? --Aidionidis 13:24, 5 December 2010 (PST)

Dictionary

The build-in dictionary is quite handy but the vocabularies seems limited. Would it be possible to replace or extend its content?

From www.the-ebook.org forum (russian), one can customize the dictionary data by replacing /system/media/reference/c11.pdb and /system/media/reference/b_and_g_dictionaries.db. The former is in Palm Dictionary format while the later is a simple Sqlite3 DB.

ADB Device not showing up in Device Manager

I cannot see an ADB device, or any unrecognized devices in device manager when I hook up my nook. It makes the happy sound, and I can see the USB drives under Disk Drives -> B&N nook USB device, and it shows up under Universal Serial Bus Controllers as a mass storage device, but I can't install the usb driver to connect via ADB. No matter what, it does not list my nook as a device. I am running Windows XP Pro SP3. Is there some setting on my computer that I need to change so I can see the ADB device I'm supposed to see? I have another computer running Windows 7, and I cannot see my nook in the devices on that computer either. I've tried with my regular nook and the nook color, and I cannot see either device. I cannot proceed with any kind of anything until I can connect. Does anyone have any suggestions? I've tried everything I can think of, including looking at the bios to see if maybe there were some settings I needed to change there. Nothing has helped.

I have the same problem, and have worked through the NookColor_USB_ADB instructions multiple times, word for word. Device does not show up in Device Manager, but does show up (twice) as "B&N Ebook Disk USB Device" under Disk Drives. I have tried uninstalling these, but they come right back when I reconnect the NC. I see no occurrence of Android Composite ADB Interface as I am supposed to. I have also tried the Easy USB method, which produces the same results. Since I had already installed the full SDK, I used the "Driver Only Pack" option from Easy USB.
This may help with others that can't find the device in Device Manager. It is listed under "USB Mass Storage Device" under the "Universal Serial Bus Controllers drop down". Double click it, click on "Details Tab", drop down menu to Hardware IDs. It should show "VID_2080"
I figured out why I couldn't install the usb device drivers, and why ADB did not recognize my nook as an android device. I was trying to install the usb drivers before I set USB Debugging to true on my Nook Color. The other thing that I did was to have the adb_usb.ini file in my user profile folder under the .android folder with the device id of 2080. See the Nook Color rooting instructions for this file. In order to turn USB debugging to true on the nook color, you need to install the setup program that gives you the interface to do this. Again, see the Nook Color rooting instructions. You have to boot from the sd card after you copy the AutoNooter onto it. I haven't rooted my plain nook yet, but it looks like the steps set this to true via tricking the nook to install it with a fake wifi update. Then you can install the usb drivers and access your nook from adb. I hope this helps other noobs like myself get over this hurdle.

Big problem with nook wifi card

Hi guys, I have a very big problem with my nook. I don't know why the wifi connection doesn't work. My nook is softrooted with nookdevs 2.4.1. When I try to browse wifi hotspots, nothing happend! It say "scanning, please wait", but on the e-ink display, near the battery icon, the wifi icon doesn't appear. I tried to downgrade to stock v1.0 firmware, then 1.4... tried to reboot those famous "six times". But nothing to do. The wifi doesn't work. Please, help me.... realy. You don't know how many hours I've lost for nothing....

This is my logcat: http://www.2shared.com/document/_86FtrMu/logcat.html

Thanks in advance for your time, Simone.

EDIT: I remember that the same day that I done the firmware ugrade I changed my access point wifi channel in 13. I live in Italy and here there no compatibility problems using wifi card on 1 -> 14 channel. But the nook is US made... so its wifi card is not compatible with channels 12 and 13 that aren't used in US. Simone

I have a similar problem with a nook 3g/wifi running 2.5.1. Before flashing, wifi worked fine. Now it won't connect at all, it just sits saying connecting then eventally says disconnected. logcat shows nothing at all while this happens.

Any ideas? Is there still a link to 2.4.1 available so I can try that instead? --Craig 08:12, 11 March 2011 (PST)

Proof of concept -- rooting 1.5

I have managed to 'break in' to a nook running unpatched 1.5, via a security flaw in the web browser. See my user page for the details so far. It's not very user-friendly, but I hope to release a much friendler version very soon. Right now, I only have access as the 'system' user, which can launch adbd, but doesn't have root privileges. There should be a way, now that I'm in, to escalate those privileges. Comments much desired! Neilk 13:26, 24 February 2011 (PST)

I made a new version of the exploit script that may or may not work -- haven't tested it yet. This one should launch adbd as user 'system' on your nook. Load this URL in the nook 1.5 browser. If it doesn't crash, reload it. If it does crash, try to connect with adb. If it doesn't connect, load the URL again. Don't give up -- this is not a deterministic method and it might take dozens of tries to work. Or it might never work without minor tweaks -- I'm not sure yet. I'd love to hear from anyone with a new 1.5 nook who achieves success. Neilk 15:06, 24 February 2011 (PST)

Very Poor Audio Quality

Nook Color at B&N update 1.1.0 - rooted

I've experienced a large difference in audio quality between my T-Mobile G2 and my Nook Color. Has anyone found an Equalizer that will allow bass and treble to be adjusted to a satisfactory range?


-- Having trouble with a "return to stock" reflash - I've rooted my nook color then after a few days suddenly it started behaving erratically, rebooting through cycles. I've been trying to reflash back to stock and I am not able to get it to reload back to stock. I've gone through the 8 cycles. it indicates a new versionof software is being loaded. when it reboots, the Android splash screen still is there, along with softkeys, but no su. Any idea on how to get back to stock so I can re-root?

Whither current reading button?

I have rooted my Nook Color and now the open book shows up at the bottom of the screen, but clicking (tapping) it does nothing. Is there a fix for this or must I just live with having to fumble over to Library, etc.? My nook had been updated to 1.5. After stumbling around a bit, I succeeded in getting Rooter to push me to the rooted world. (Archie Strong)

In answer to the question above my note--see the following page, where I describe how I got back to using nooter successfully: http://nooktalk.net/news/nook-color-firmware-update-1-1-0

I also failed to really get back to the pre-root state, but am now in working order. Of course, the "current reading button" problem still exists!

A doubt with icons

Now my nook is softrooted with nookdevs 2.5.1. Is it normal that the default nookTaskManager and nookMarket icons have this grey background?

Here the picture:

img00020201102221619.jpg

Thanks again, Simone.

library sync

Hi All! I have a Nook Ereader and i love it! I have set up an old computer i had laying around to turn on, start calibre, download about 10 news papers, create a catalog (clibre2opds) upload it all to my dropbox and shutdown. I am looking for a way to sync my library to my nook automatically (now I connect it via USB to the computer that is not in my room where I sleep). I would be even happer if it could do it over the web (I travel a lot). I tried with the dropbox app. no luck. It does not have sync capabilities. I can do it with trook, but it is not automatic. Does anyone have any ideas how to do it? Maybe install the linux desktop cli version of dropbox? Maybe there is an opds library app that can sync it? Or use the DNS hack in some way shape or form? thanks in advance for the tips and idea, Marbs.

Launcher disappears from my b/w nook

I have a Nook, 1002*, that I successfully rooted. The new Launcher choice appeared, then disappeared after the last reboot. If I hold the right > and reboot, Launcher appears again, then when I do the additional reboot as instructed, the Launcher disappears again. I have WiFi enabled. I expect that I am getting an automatic BN update via Wifi each time. If that is so, does it mean I cannot turn Wifi back on without losing my softroot?

Thanks everyone

I just got my nook and I was looking on information on how to make the battery last longer. I found this great site on how to extend the life of your batteries or to restore old batteries using battery reconditioning http://justlivejustbe.com/batteryreconditioning/how-to-extend-the-life-of-your-batteries

--

Reusing the SD Card after rooting the Nook Touch.

Hi there,

I rooted my Nook Touch through JFreke's method. No problems so far.

Now the SD card is somehow formatted as a 75 MB or so disc. Is it possible to restore it to its original 3.5 GB state?

Kind regards

Kon Dan

SD Card problem

If your SD card is showing less storage than it actually has quick fix is to format it from the device itself:

go Settings>Device Info>SD Card: 1. Unmount SD Card 2. Format SD Card > Format 3. Enjoy :)

Regards Etuil


Help!!!!!

My girlfriend decided to load a cm7 nightly update on her nook through cwm on rooted cm7 stable. Now when you boot it up the CM7 boot image shows up then there is just a blank screen. I am familiar with adb. I have a xoom and have used adb to flash roms, cwm, and rooted updates of HC. I tried to power cycle it 8 times...nothing happened. I removed the battery....nothing happened. ADB did not work either. Everytime I type in "adb devices" it did not read the nook. Any help would be greatly appriecated.


Thank You, Nico

Retrieved from "http://nookdevs.com/Forum"
Personal tools
Navigation
Nook Classic
Nook Simple Touch
Nook Tablet
Google AdSense